Search
j0ke.net Open Build Service
>
Projects
>
server:monitoring
:
netflow
>
nprobe
> nprobe.spec
Sign Up
|
Log In
Username
Password
Cancel
Overview
Repositories
Revisions
Requests
Users
Advanced
Attributes
Meta
File nprobe.spec of Package nprobe (Revision 70)
Currently displaying revision
70
,
show latest
#!BuildIgnore: post-build-checks %define _default_patch_fuzz 3 %define reldate 130209_svn3198 %define sodate %(date +%%y%%m%%d) %define pfringver 5.5.2-svn Name: nprobe Version: 6.11 Release: 1 Group: System Summary: Netflow Probe Url: http://www.nmon.net/ License: GPL Source0: %{name}_%{version}.%{reldate}_proplugins.tgz Source1: GeoLiteCity.dat.gz Source2: GeoIPASNum.dat.gz Source3: GeoIPASNumv6.dat.gz Source5: UsersGuide.pdf Source6: nprobe.init Source7: sysconfig.nprobe Source8: nDPI.tar.bz2 Source9: PF_RING-%{pfringver}.tar.bz2 Patch1: nprobe-%{version}-GeoIPdat-dir.patch Patch2: nprobe-%{version}-configure.in.patch Patch3: nprobe.h-prefix.patch BuildRoot: %{_tmppath}/%{name}-%{version}-root NoSource: 0 %if 0%{?rhel_version} || 0%{?centos_version} || 0%{?fedora_version} BuildRequires: gawk which BuildRequires: tcp_wrappers libpcap-devel %endif %if 0%{?fedora_version} >= 7 || 0%{?rhel_version} >= 600 || 0%{?centos_version} >= 6 BuildRequires: tcp_wrappers-devel %endif %if 0%{?suse_version} > 1010 BuildRequires: awk libpcap-devel tcpd-devel %endif %if 0%{?suse_version} > 0 && 0%{?suse_version} <= 1010 BuildRequires: awk libpcap tcpd-devel %endif %if 0%{?suse_version} PreReq: %insserv_prereq %fillup_prereq %endif BuildRequires: autoconf automake libtool gcc-c++ grep sed flex bison BuildRequires: pcre-devel mysql-devel libGeoIP-devel >= 1.4.5 lksctp-tools-devel python-devel openssl-devel BuildRequires: sqlite-devel >= 3.0 BuildRequires: libpfring-devel BuildRequires: subversion %description Light, fast, resource-savvy NetFlow v5 and v9 probe that can be used stand-alone, with commercial products, or with ntop. %package devel Group: Development/Libraries Summary: NProbe devel files %description devel NProbe development files. %prep %setup -n %{name}_%{version}.%{reldate}_proplugins -a 8 -b 9 %patch1 %patch2 %patch3 cp %{S:1} . cp %{S:2} . cp %{S:3} . cp %{S:5} . cd .. mv PF_RING-%{pfringver} PF_RING %build # pre build libpfring & libpcap of PF_RING pre=`pwd` cd ../PF_RING/userland/lib ./configure make cd ../libpcap ./configure make cd ${pre} if [ ! -f ./configure ]; then ./autogen.sh fi CFLAGS="$RPM_OPT_FLAGS" LIB="%{_lib}" ./configure \ --enable-shared \ --enable-static \ --prefix=%{_prefix} \ --libdir=%{_libdir} \ --sysconfdir=%{_sysconfdir} \ --mandir=%{_mandir} cd nDPI ; ./configure ; make ; cd .. %__make %install gunzip GeoLiteCity.dat.gz gunzip GeoIPASNum.dat.gz gunzip GeoIPASNumv6.dat.gz %__make DESTDIR=%{buildroot} install %__install -d %{buildroot}%{_prefix}/lib/nprobe %__install -d %{buildroot}%{_prefix}/lib/nprobe/plugins cp GeoLiteCity.dat %{buildroot}%{_prefix}/lib/nprobe/ cp GeoIPASNum.dat %{buildroot}%{_prefix}/lib/nprobe/ cp GeoIPASNumv6.dat %{buildroot}%{_prefix}/lib/nprobe/ find %{buildroot}%{_prefix}/lib/nprobe/plugins -type l -exec rm {} \; %__install -D -m755 %{S:6} %{buildroot}%{_sysconfdir}/init.d/%{name} %if 0%{?suse_version} %__install -D -m644 %{S:7} %{buildroot}/var/adm/fillup-templates/sysconfig.%{name} %else %__install -D -m644 %{S:7} %{buildroot}%{_sysconfdir}/sysconfig/%{name} %endif %__install -d -m755 %{buildroot}%{_sbindir} ln -sf ../../etc/init.d/nprobe %{buildroot}%{_sbindir}/rcnprobe # drop .la files # *** Warning: Linking the shared library libdbPlugin.la against the # *** static library /usr/src/packages/BUILD/nprobe_6.9.11_120912_svn2881_proplugins/../PF_RING/userland/libpcap/libpcap.a is not portable! # *** Warning: Linking the shared library libdbPlugin.la against the # *** static library /usr/src/packages/BUILD/nprobe_6.9.11_120912_svn2881_proplugins/../PF_RING/userland/lib/libpfring.a is not portable! # *** Warning: Linking the shared library libdbPlugin.la against the # *** static library /usr/src/packages/BUILD/nprobe_6.9.11_120912_svn2881_proplugins/nDPI/src/lib/.libs/libndpi.a is not portable! find %{buildroot} -iname \*.la -exec rm {} \; %clean rm -rf %{buildroot} %post %if 0%{?suse_version} %fillup_and_insserv %else chkconfig --add %{name} || : %endif %postun %if 0%{?suse_version} %restart_on_update nprobe %insserv_cleanup %else if [ "$1" == "1" ] ; then # upgrade service %{name} restart || : fi if [ "$1" == "0" ] ; then # uninstall chkconfig --del %{name} || : fi %endif %preun %if 0%{?suse_version} %stop_on_removal nprobe %else service %{name} stop || : %endif %files %defattr(-,root,root) %doc UsersGuide.pdf README %{_sbindir}/rcnprobe %{_bindir}/nprobe %dir %{_prefix}/lib/nprobe %dir %{_prefix}/lib/nprobe/plugins %{_prefix}/lib/nprobe/GeoIPASNum.dat %{_prefix}/lib/nprobe/GeoIPASNumv6.dat %{_prefix}/lib/nprobe/GeoLiteCity.dat %{_prefix}/lib/nprobe/plugins/libdbPlugin-%{version}.%{sodate}.so #%{_prefix}/lib/nprobe/plugins/libdbPlugin.la %{_prefix}/lib/nprobe/plugins/libbgpPlugin-%{version}.%{sodate}.so #%{_prefix}/lib/nprobe/plugins/libbgpPlugin.la %{_libdir}/libnprobe-%{version}.%{sodate}.so #%{_libdir}/libnprobe.la %{_libdir}/libnprobe.so %{_sysconfdir}/init.d/%{name} %if 0%{?suse_version} /var/adm/fillup-templates/sysconfig.%{name} %else %{_sysconfdir}/sysconfig/%{name} %endif %files devel %defattr(-,root,root) %{_libdir}/libnprobe.a %if 0%{?sles_version} != 11 && 0%{?suse_version} < 1110 || 0%{?centos_version} > 0 && 0%{?centos_version} < 6 || 0%{?rhel_version} > 0 && 0%{?rhel_version} < 600 || 0%{?sl_version} > 0 && 0%{?sl_version} < 600 %{_prefix}/lib/nprobe/plugins/libdbPlugin.a %{_prefix}/lib/nprobe/plugins/libbgpPlugin.a %endif %changelog * Thu Jul 28 2011 Carsten Schoene <cs@linux-administrator.com> - 6.5.1-1 - update to release 6.5.1 * Sun Jul 24 2011 Carsten Schoene <cs@linux-administrator.com> - 6.4.0-2 - updated GeoIPASN & GeoLiteCity databases - added initscript & sysconfig file * Mon Apr 04 2011 Carsten Schoene <cs@linux-administrator.com> - 6.4.0-1 - update to release 6.4.0 - reworked GeoIP path patch - updated GeoIPASN & GeoLiteCity databases * Sun Feb 06 2011 Carsten Schoene <cs@linux-administrator.com> - 6.1.6-1 - update to release 6.1.6 - updated GeoIPASN & GeoLiteCity databases * Fri Jan 29 2011 Carsten Schoene <cs@linux-administrator.com> - 6.1.5-1 - update to release 6.1.5 - updated GeoIPASN & GeoLiteCity databases * Tue Dec 14 2010 Carsten Schoene <cs@linux-administrator.com> - 6.1.1-1 - update to release 6.1.1 - updated GeoIPASN & GeoLiteCity databases * Sat Nov 06 2010 Carsten Schoene <cs@linux-administrator.com> - 6.0.2-3 - remove symlinks to plugins in plugindir (conflicts) * Thu Nov 04 2010 Carsten Schoene <cs@linux-administrator.com> - 6.0.2-2 - added BuildRequires for - sqlite3 - libpfring * Wed Nov 03 2010 Carsten Schoene <cs@linux-administrator.com> - 6.0.2-1 - update to release 6.0.2-102010 * Tue Oct 12 2010 Carsten Schoene <cs@linux-administrator.com> - 5.8.1-3 - update to release 090910 * Tue Sep 07 2010 Carsten Schoene <cs@linux-administrator.com> - 5.8.1-2 - added an updated util.c - updated GeoIP databases * Mon Sep 06 2010 Carsten Schoene <cs@linux-administrator.com> - 5.8.1-1 - update to release 5.8.1 * Tue Jun 15 2010 Carsten Schoene <cs@linux-administrator.com> - 5.6.2-1 - update to release 5.6.2 * Tue Jun 08 2010 Carsten Schoene <cs@linux-administrator.com> - 5.6.0-1 - initial build