Logoj0ke.net Open Build Service > Projects > server:monitoring > nrpe3 > nrpe.spec
Sign Up | Log In

File nrpe.spec of Package nrpe3 (Revision efaf26e10b50477c10834f9b63c0f06a)

Currently displaying revision efaf26e10b50477c10834f9b63c0f06a, show latest

 
1
#!BuildIgnore:          post-build-checks
2
3
%if 0%{?fedora} > 19
4
%global _hardened_build 1
5
%endif
6
%define nsport 5666
7
%define myname  nrpe
8
%define nsusr nagios
9
%define nsgrp nagios
10
BuildRoot:  %{_tmppath}/%{myname}-%{version}-root
11
12
Name:   nagios-%{myname}
13
Version: 3.2.1
14
Release: 9%{?dist}
15
Summary: Host/service/network monitoring agent for Nagios
16
Group:   Application/System
17
License: GPLv2
18
URL: http://www.nagios.org
19
Source0: https://github.com/NagiosEnterprises/nrpe/archive/%{myname}-%{version}.tar.gz
20
Source1: nrpe.sysconfig
21
Source2: nrpe-tmpfiles.conf
22
Source3: nrpe.README.SELinux.rst
23
Source4: nrpe_epel6.te
24
Source5: nrpe_epel7.te
25
Source6: nrpe_epel.fc
26
Source7: nrpe.service.epel
27
Source8: nrpe.xinetd
28
29
Patch3: nrpe-0003-Include-etc-npre.d-config-directory.patch
30
Patch4: nrpe-default-config.patch
31
Patch13: nrpe-0013-service-rhel6.patch
32
33
# For reconfiguration
34
BuildRequires: autoconf, automake, libtool
35
BuildRequires: gcc
36
BuildRequires: openssl, openssl-devel
37
BuildRequires: checkpolicy
38
%if 0%{?suse_version} || 0%{?sles_version}
39
BuildRequires: pwdutils
40
Requires:   pwdutils
41
%endif
42
%if 0%{?rhel} > 5
43
BuildRequires: selinux-policy-devel
44
%endif
45
%if 0%{?fedora} > 17 || 0%{?rhel} > 6
46
BuildRequires: systemd-units
47
%endif
48
49
%if 0%{?fedora} < 28 && 0%{?rhel} < 8 && 0%{?!sles_version}
50
BuildRequires: tcp_wrappers-devel
51
%endif
52
53
Requires(pre): %{_sbindir}/useradd, %{_sbindir}/usermod
54
55
%if 0%{?el6} || 0%{?suse_version} || 0%{?sles_version}
56
Requires(preun): /sbin/service, /sbin/chkconfig
57
Requires(post): /sbin/chkconfig, /sbin/service
58
Requires(postun): /sbin/service
59
Requires: initscripts
60
%else
61
Requires(post): systemd
62
Requires(preun): systemd
63
Requires(postun): systemd
64
%endif
65
66
# owns /etc/nagios
67
Requires: nagios-plugins
68
Provides: nagios-nrpe = %{version}-%{release}
69
70
%description
71
Nrpe is a system daemon that will execute various Nagios plugins
72
locally on behalf of a remote (monitoring) host that uses the
73
check_nrpe plugin.  Various plugins that can be executed by the
74
daemon are available at:
75
http://sourceforge.net/projects/nagiosplug
76
77
This package provides the core agent.
78
79
%package -n nagios-plugins-nrpe3
80
Summary: Provides nrpe plugin for Nagios
81
Requires: nagios-plugins
82
Provides: check_nrpe = %{version}-%{release}
83
Group: Application/System
84
85
%description -n nagios-plugins-nrpe3
86
Nrpe is a system daemon that will execute various Nagios plugins
87
locally on behalf of a remote (monitoring) host that uses the
88
check_nrpe plugin.  Various plugins that can be executed by the
89
daemon are available at:
90
http://sourceforge.net/projects/nagiosplug
91
92
This package provides the nrpe plugin for Nagios-related applications.
93
94
%if 0%{?rhel} > 5
95
%package selinux
96
Summary:          SELinux context for %{myname}
97
Requires:         %name = %version-%release
98
Requires(post):   policycoreutils
99
Requires(postun): policycoreutils
100
Group: Application/System
101
102
%description selinux
103
SElinux context for %{myname}.
104
%endif
105
106
%prep
107
%setup -q -n %{myname}-%{version}
108
%patch3 -p1 -b .include_etc_npre_d
109
%patch4 -p0 -b .default-config-nrpe
110
%patch13 -p1 -b .fix_service_rhel6
111
112
113
%build
114
CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="%{?__global_ldflags}" \
115
%configure \
116
    --with-init-dir=%{_initrddir} \
117
    --with-nrpe-port=%{nsport} \
118
    --with-nrpe-user=%{nsusr} \
119
    --with-nrpe-group=%{nsgrp} \
120
    --with-piddir=/var/run/nrpe \
121
    --bindir=%{_sbindir} \
122
    --libdir=/doesnt/matter/ \
123
    --libexecdir=%{_prefix}/lib/nagios/plugins \
124
    --datadir=%{_datadir}/nagios \
125
    --sysconfdir=%{_sysconfdir}/nagios \
126
    --localstatedir=%{_localstatedir}/run/ \
127
    --enable-command-args
128
129
make %{?_smp_mflags} all
130
131
%if 0%{?rhel} > 5
132
## SELinux configs
133
mkdir selinux
134
install -pm 644 %{SOURCE3} README.SELinux.rst
135
%if 0%{?rhel} < 7
136
cp -p %{SOURCE4} selinux/%{myname}_epel.te
137
%else
138
cp -p %{SOURCE5} selinux/%{myname}_epel.te
139
%endif
140
cp -p %{SOURCE6} selinux/%{myname}_epel.fc
141
touch selinux/%{myname}_epel.if
142
make -f %{_datadir}/selinux/devel/Makefile
143
%endif
144
145
%install
146
rm -rf %{buildroot}
147
%if 0%{?el6}%{?el7} || 0%{?sles_version}
148
## If we are EL6 we want the old style sysV init script
149
%if 0%{?el6} || 0%{?sles_version}
150
install -D -p -m 0755 startup/default-init %{buildroot}/%{_initrddir}/nrpe
151
%else
152
## If we are EL7 we want the home crafted systemd service due to problems
153
install -D -m 0644 -p %{SOURCE7} %{buildroot}%{_unitdir}/%{myname}.service
154
%endif
155
%else
156
## If we are Fedora we want the upstream systemd service file
157
install -D -m 0644 -p startup/default-service %{buildroot}%{_unitdir}/%{myname}.service
158
%endif
159
install -D -p -m 0644 sample-config/nrpe.cfg %{buildroot}/%{_sysconfdir}/nagios/%{myname}.cfg
160
install -D -p -m 0755 src/nrpe %{buildroot}/%{_sbindir}/nrpe
161
install -D -p -m 0755 src/check_nrpe %{buildroot}/%{_prefix}/lib/nagios/plugins/check_nrpe3
162
%if 0%{?!sles_version}
163
install -D -p -m 0644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/sysconfig/%{myname}
164
%endif
165
install -d %{buildroot}%{_sysconfdir}/nrpe.d
166
install -d %{buildroot}%{_sysconfdir}/nagios/nrpe.d
167
install -d %{buildroot}%{_localstatedir}/run/%{myname}
168
%if 0%{?fedora} > 14 || 0%{?rhel} > 6
169
install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_tmpfilesdir}/%{myname}.conf
170
%endif
171
%if 0%{?rhel} >5
172
# Selinux configs
173
install -p -m 644 -D %{myname}_epel.pp $RPM_BUILD_ROOT%{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp
174
%endif
175
install -d -m 0755 ${RPM_BUILD_ROOT}/etc/xinetd.d
176
install -m 644 %{SOURCE8} ${RPM_BUILD_ROOT}/etc/xinetd.d/nrpe
177
178
%pre
179
getent group %{nsgrp} >/dev/null || groupadd -r %{nsgrp}
180
getent passwd %{nsusr} >/dev/null || \
181
%{_sbindir}/useradd -c "NRPE user for the NRPE service" -d %{_localstatedir}/run/%{myname} -r -g %{nsgrp} -s /sbin/nologin %{nsusr} 2> /dev/null || :
182
%if 0%{?!suse_version}
183
getent group %{nsgrp} >/dev/null && %{_sbindir}/usermod -a -G %{nsgrp} %{nsusr} || :
184
%endif
185
if grep ^nrpe /etc/services; then
186
        : # service entry exists
187
else
188
        echo -e "nrpe\t5666/tcp\t# nagios nrpe" >> /etc/services
189
fi
190
191
%preun
192
%if 0%{?el6} || 0%{?suse_version}
193
if [ $1 = 0 ]; then
194
    /sbin/service %{myname} stop > /dev/null 2>&1 || :
195
    /sbin/chkconfig --del %{myname} || :
196
fi
197
%else
198
%systemd_preun nrpe.service
199
%endif
200
201
%post
202
%if 0%{?el6} || 0%{?suse_version}
203
/sbin/chkconfig --add %{myname} || :
204
%else
205
%systemd_post nrpe.service
206
%endif
207
touch %{_sysconfdir}/nagios/%{myname}_local.cfg
208
if [ -d /etc/sudoers.d ] ; then
209
        cat > /etc/sudoers.d/50_nagios << EOF
210
nagios          ALL=(ALL) NOPASSWD: /usr/lib/nagios/plugins/,/usr/lib64/nagios/plugins/
211
Defaults:nagios !requiretty
212
Defaults:nagios !env_keep
213
EOF
214
chmod 0440 /etc/sudoers.d/50_nagios
215
216
elif [ -f /etc/sudoers ] ; then
217
        if [ -z "`grep ^nagios /etc/sudoers`" ] ; then
218
                echo "nagios          ALL=(ALL) NOPASSWD: /usr/lib/nagios/plugins/,/usr/lib64/nagios/plugins/" >> /etc/sudoers
219
        fi
220
        if [ -z "`grep ^Defaults:nagios`" ] ; then
221
                echo "Defaults:nagios !requiretty" >> /etc/sudoers
222
                echo "Defaults:nagios !env_keep" >> /etc/sudoers
223
        fi
224
fi
225
226
%postun
227
%if 0%{?el6} || 0%{?suse_version}
228
if [ "$1" -ge "1" ]; then
229
    /sbin/service %{myname} condrestart > /dev/null 2>&1 || :
230
fi
231
%else
232
%systemd_postun_with_restart nrpe.service
233
%endif
234
235
%if 0%{?rhel} >5
236
%post selinux
237
%if 0%{?el6}
238
if [ "$1" -le "1" ]; then # Fist install
239
   semodule -i %{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp 2>/dev/null || :
240
   fixfiles -R %{name} restore || :
241
   /sbin/service %{myname} condrestart > /dev/null 2>&1  || :
242
fi
243
%else
244
if [ "$1" -le "1" ]; then # Fist install
245
   semodule -i %{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp 2>/dev/null || :
246
   fixfiles -R %{name} restore || :
247
   %systemd_postun_with_restart %{myname}.service
248
fi
249
%endif
250
%endif
251
252
%if 0%{?rhel} >5
253
%preun selinux
254
%if 0%{?el6}
255
if [ "$1" -lt "1" ]; then # Final removal
256
    semodule -r %{myname}_epel 2>/dev/null || :
257
    fixfiles -R %{name} restore || :
258
    /sbin/service %{myname} condrestart > /dev/null 2>&1 || :
259
fi
260
%else
261
if [ "$1" -lt "1" ]; then # Final removal
262
    semodule -r %{myname}_epel 2>/dev/null || :
263
    fixfiles -R %{name} restore || :
264
    %systemd_postun_with_restart %{myname}.service
265
fi
266
%endif
267
%endif
268
269
%if 0%{?rhel} >5
270
%postun selinux
271
if [ "$1" -ge "1" ]; then # Upgrade
272
    # Replaces the module if it is already loaded
273
    semodule -i %{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp 2>/dev/null || :
274
     # no need to restart the daemon
275
fi
276
%endif      
277
278
%files
279
%defattr(0755,root,root)
280
%if 0%{?el6} || 0%{?sles_version}
281
%{_initrddir}/nrpe
282
%else
283
%{_unitdir}/%{myname}.service
284
%endif
285
%config(noreplace) %{_sysconfdir}/xinetd.d/nrpe
286
%{_sbindir}/nrpe
287
%dir %{_sysconfdir}/nrpe.d
288
%dir %{_sysconfdir}/nagios
289
%dir %{_sysconfdir}/nagios/nrpe.d
290
%config(noreplace) %{_sysconfdir}/nagios/nrpe.cfg
291
%if 0%{?!sles_version}
292
%config(noreplace) %{_sysconfdir}/sysconfig/%{myname}
293
%endif
294
%if 0%{?fedora} > 14 || 0%{?rhel} > 6
295
%config(noreplace) %{_tmpfilesdir}/%{myname}.conf
296
%endif
297
%defattr(0644,root,root)
298
%doc CHANGELOG.md LICENSE.md LEGAL README.md README.SSL.md SECURITY.md docs/NRPE.pdf
299
%dir %attr(775, %{nsusr}, %{nsgrp}) %{_localstatedir}/run/%{myname}
300
301
%files -n nagios-plugins-nrpe3
302
%defattr(0755,root,root)
303
%dir %{_prefix}/lib/nagios
304
%dir %{_prefix}/lib/nagios/plugins
305
%{_prefix}/lib/nagios/plugins/check_nrpe3
306
%doc CHANGELOG.md LICENSE.md LEGAL README.md
307
308
%if 0%{?rhel} > 5
309
%files selinux
310
%defattr(0755,root,root)
311
%doc README.SELinux.rst
312
%{_datadir}/selinux/packages/%{myname}/%{myname}_epel.pp
313
%endif
314
315
%changelog
316
* Fri Jul 26 2019 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-9
317
- Try to make this work on el8
318
319
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-8
320
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
321
322
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-7
323
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
324
325
* Tue Jul 24 2018 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-6
326
- Fix BZ#1546264
327
- Fix potential FTBFS for gcc
328
329
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-5
330
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
331
332
* Thu Mar 22 2018 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-4
333
- Remove other el5 items. Update spec
334
335
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.2.1-3
336
- Escape macros in %%changelog
337
338
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-2
339
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
340
341
* Tue Nov 21 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.1-1
342
- Update to nrpe-3.2.1
343
- Fix BZ#1485361
344
345
* Fri Aug  4 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-6
346
- Found the problem. Fixed and ready to push
347
348
* Fri Aug  4 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-5
349
- Make sure nrpe works with different selinux names between 5,6 and 7
350
- For some reason the selinux module still does not install unless by force on EL6.
351
352
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-6
353
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
354
355
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.0-5
356
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
357
358
* Fri Jul 21 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-4
359
- Forgot to up the release.
360
361
* Fri Jul 21 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-3
362
- Clean out nrpe.fc as that breaks silently 
363
364
* Wed Jul 19 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-3
365
- Remove git from release name
366
- Fix selinux lines.
367
368
* Fri Jul 14 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-2git
369
- Remember to put in a patch so the /etc/nrpe.d/ is used.
370
371
* Fri Jul 14 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.2.0-1
372
- Update to 3.2.0
373
- Add patches for 321 openssl items
374
- Remove old patches no longer needed
375
376
* Tue Jul 11 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-6
377
- Put in fix for 1204683
378
379
* Tue Jul 11 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-5
380
- Add comments to nrpe.cfg to alert user on RHBZ #1318773
381
- Backport ipv6 patch for problem
382
383
* Fri Jul  7 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-4
384
- Fix patch name. Silly human. Do a fedpkg srpm before build.
385
386
* Fri Jul  7 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-3
387
- Fix crashing bug if username is not defined.
388
389
* Wed Jul  5 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-2
390
- Fix bug due to /etc/nrpe.d/ includes was above other defined entries BZ# 1467971
391
- I am not updating to 3.2.0 for a bit in order to smush out problems here.
392
393
* Wed Jun 14 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.1-1
394
- Update to 3.1.1
395
- Remove git patch
396
- Add pid_dir configure statement.
397
398
* Tue May  2 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.0-3
399
- Grab updates from upstream to see why nrpe fails on fedora but not rhel
400
401
* Wed Apr 26 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.0-2
402
- Move to using original nirik nrpe service file for systemd. It worked and the others dont
403
- NRPE fails to run using a /var/run/nrpe/ directory so trying to build without it.
404
405
* Thu Apr 20 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.1.0-1
406
- update to 3.1.0
407
- put in fix for format-error
408
- remove patches not needed.
409
410
* Thu Mar 23 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-6
411
- Redo the nagios policy to lower its all the permissions.
412
413
* Wed Mar 22 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-5
414
- Put in patches from GIT to fix noise problems
415
- Put in patch for RHEL6 systems to regain vars
416
- Put in initial patch for selinux on EPEL
417
- Remove el4 macros as this won't work there anyway.
418
419
* Fri Mar  3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-5
420
- Remember to add the patch so it can build.
421
422
* Fri Mar  3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-4
423
- Fix systemd to use correct service file.
424
- Add reload rule
425
426
* Fri Mar  3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-3
427
- fix the systemd service file to better match needs.
428
429
* Fri Mar  3 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-2
430
- fix the statedir to look at /var/run/nrpe
431
432
* Mon Feb  6 2017 Stephen Smoogen <smooge@fedoraproject.org> - 3.0.1-1
433
- Update to 3.0.1
434
- Add a temp patch to get it to work with openssl v110 for F25
435
436
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.15-8
437
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
438
439
* Tue Sep  8 2015 Peter Robinson <pbrobinson@fedoraproject.org> 2.15-7
440
- Use %%configure macro as it deals with config.sub/guess and various flags properly
441
442
* Fri Sep 04 2015 Scott Wilkerson <swilkerson@fedoraproject.org> - 2.15-6
443
- Fix spec file for missing /usr/share/libtool/config/config.guess
444
445
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-5
446
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
447
448
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-4
449
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
450
451
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-3
452
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
453
454
* Thu May 1 2014 Sam Kottler <skottler@fedoraproject.org> - 2.15.2
455
- Add patch to mitigate CVE-2014-2913
456
457
* Mon Jan 27 2014 Sam Kottler <skottler@fedoraproject.org> - 2.15.1
458
- Update to 2.15
459
460
* Wed Oct 16 2013 Peter Lemenkov <lemenkov@gmail.com> - 2.14-5
461
- Allow building for aarch64 (rhbz #926244)
462
- Allow user to redefine default commands (rhbz #963703)
463
464
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-4
465
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
466
467
* Wed May 22 2013 Kevin Fenzi <kevin@scrye.com> 2.14-3
468
- Apply patch from bug 860988 to handle RHEL versions and systemd
469
- Apply patch from bug 957567 to fix condrestart so nrpe restarts on upgrade.
470
- Rework systemd and service scriptlets and requires.
471
- Harden Fedora 19+ builds
472
473
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14-2
474
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
475
476
* Mon Jan 14 2013 Mark Chappell <tremble@tremble.org.uk> - 2.14
477
- Version 2.14
478
479
* Mon Jan 14 2013 Mark Chappell <tremble@tremble.org.uk> - 2.13-2
480
- #860982 Mistake in service file
481
- #860985 nrpe shouldn't own /etc/nagios (from nagios-common)
482
483
* Mon Sep 17 2012 Peter Lemenkov <lemenkov@gmail.com> - 2.13-1
484
- Ver. 2.13
485
486
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-21
487
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
488
489
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-20
490
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
491
492
* Thu Sep 22 2011 Peter Lemenkov <lemenkov@gmail.com> - 2.12-19
493
- Disable systemd stuff in EPEL
494
495
* Sat Sep 17 2011 Ruben Kerkhof <ruben@rubenkerkhof.com> - 2.12-18
496
- Let systemd create /var/run/nrpe. Fixes rhbz #656641
497
498
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-17
499
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
500
501
* Mon Oct 25 2010 Peter Lemenkov <lemenkov@gmail.com> - 2.12-16
502
- Issue with SELinux was resolved (see rhbz #565220#c25). 2nd try.
503
504
* Wed Sep 29 2010 jkeating - 2.12-15
505
- Rebuilt for gcc bug 634757
506
507
* Sat Sep 11 2010 Peter Lemenkov <lemenkov@gmail.com> - 2.12-14
508
- Issue with SELinux was resolved (see rhbz #565220).
509
510
* Fri Jun 18 2010 Peter Lemenkov <lemenkov@gmail.com> - 2.12-13
511
- Init-script enhancements (see rhbz #247001, #567141 and #575544)
512
513
* Mon Oct 26 2009 Peter Lemenkov <lemenkov@gmail.com> - 2.12-12
514
- Do not own %%{_libdir}/nagios/plugins ( bz# 528974 )
515
- Fixed building against tcp_wrappers in Fedora ( bz# 528974 )
516
517
* Thu Sep 24 2009 Peter Lemenkov <lemenkov@gmail.com> - 2.12-11
518
- Fixed BZ# 515324
519
520
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.12-10
521
- rebuilt with new openssl
522
523
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-9
524
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
525
526
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-8
527
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
528
529
* Sat Feb 21 2009 Mike McGrath <mmcgrath@redhat.com> - 2.12-7
530
- Re-fix for 477527
531
532
* Mon Feb  2 2009 Peter Lemenkov <lemenkov@gmail.com> - 2.12-6
533
- Fixed BZ# 449174
534
- Clean up (in order to disable rpmlint warnings)
535
536
* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.12-5
537
- rebuild with new openssl
538
539
* Sun Dec 21 2008 Mike McGrath <mmcgrath@redhat.com> - 2.12-4
540
- Added some doc lines for ticket 477527
541
542
* Fri Dec 19 2008 Mike McGrath <mmcgrath@redhat.com> - 2.12-3
543
- Added Provides: nagios-nrpe
544
545
* Fri Dec 19 2008 Mike McGrath <mmcgrath@redhat.com> - 2.12-2
546
- Upstreamreleased new version
547
548
* Tue Feb 12 2008 Mike McGrath <mmcgrath@redhat.com> - 2.7-6
549
- Rebuild for gcc43
550
551
* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 2.7-5
552
 - Rebuild for deps
553
554
* Wed Aug 22 2007 Mike McGrath <mmcgrath@redhat.com> 2.7-4
555
- License Change
556
- Rebuild for BuildID
557
558
* Fri Feb 23 2007 Mike McGrath <mmcgrath@redhat.com> 2.7-1
559
- Upstream released new version
560
561
* Sun Jul 23 2006 Mike McGrath <imlinux@gmail.com> 2.5.2-3
562
- no longer owns libdir/nagios
563
- buildrequires tcp_wrappers
564
565
* Sun Jul 23 2006 Mike McGrath <imlinux@gmail.com> 2.5.2-2
566
- Specify bogus libdir so rpmlint won't complain
567
568
* Mon Jul 03 2006 Mike McGrath <imlinux@gmail.com> 2.5.2-1
569
- Upstream released new version
570
571
* Sun Mar 12 2006 Mike McGrath <imlinux@gmail.com> 2.4-3
572
- Added description to useradd statement
573
574
* Sun Mar 05 2006 Mike McGrath <imlinux@gmail.com> 2.4-2
575
- Added proper SMP build flags
576
- Added %%{?dist} tag
577
- Added reload to nrpe script
578
- Updated to 2.4, changes include:
579
- Added option to allow week random seed (Gerhard Lausser)
580
- Added optional command line prefix (Sean Finney)
581
- Added ability to reload config file with SIGHUP
582
- Fixed bug with location of dh.h include file
583
- Fixed bug with disconnect message in debug mode
584
585
* Sat Feb 04 2006 Mike McGrath <imlinux@gmail.com> 2.3-1
586
- Created a Fedora friendly spec file
587
588
* Mon Jan 23 2006 Andreas Kasenides ank<@>cs.ucy.ac.cy
589
- fixed nrpe.cfg relocation to sample-config
590
- replaced Copyright label with License
591
- added --enable-command-args to enable remote arg passing (if desired can be disabled by commenting out)
592
593
* Wed Nov 12 2003 Ingimar Robertsson <iar@skyrr.is>
594
- Added adding of nagios group if it does not exist.
595
596
* Tue Jan 07 2003 James 'Showkilr' Peterson <showkilr@showkilr.com>
597
- Removed the lines which removed the nagios user and group from the system
598
- changed the patch release version from 3 to 1
599
600
* Mon Jan 06 2003 James 'Showkilr' Peterson <showkilr@showkilr.com>
601
- Removed patch files required for nrpe 1.5
602
- Update spec file for version 1.6 (1.6-1)
603
604
* Sat Dec 28 2002 James 'Showkilr' Peterson <showkilr@showkilr.com>
605
- First RPM build (1.5-1)
606