File x264.spec of Package x264 (Revision 392cddf734ffce272d46a67018606064)
Currently displaying revision 392cddf734ffce272d46a67018606064, show latest
x
1
# norootforbuild
2
#!BuildIgnore: post-build-checks
3
%define binname x264
4
%define realname libx264
5
%define soname 67
6
%define svn 20090627
7
%define sonamecompa 66
8
%define svncompa 20090228
9
%define sonamecompb 65
10
%define svncompb 20090119
11
%define sonamecompc 64
12
%define svncompc 20081001
13
14
Name: %{binname}
15
Summary: A free h264/avc encoder - encoder binary.
16
Version: 0.0svn%{svn}
17
Release: 15
18
License: GNU General Public License (GPL)
19
Group: Productivity/Multimedia/Video
20
URL: http://developers.videolan.org/x264.html
21
Source0: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{svn}-2245.tar.bz2
22
Source1: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{svncompa}-2245.tar.bz2
23
Source2: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{svncompb}-2245.tar.bz2
24
Source3: ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{svncompc}-2245.tar.bz2
25
BuildRoot: %{_tmppath}/build-root-%{name}
26
Requires: %{realname}-%{soname} = %{version}-%{release}
27
BuildRequires: nasm
28
BuildRequires: yasm >= 0.7.1
29
30
%description
31
x264 is a free library for encoding next-generation H264/AVC video
32
streams. The code is written from scratch by Laurent Aimar, Loren
33
Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans
34
Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and
35
Alex Wright. It is released under the terms of the GPL license. This
36
package contains a shared library and a commandline tool for encoding
37
H264 streams. This library is needed for mplayer/mencoder for H264
38
encoding support.
39
40
Encoder features:
41
- CAVLC/CABAC
42
- Multi-references
43
- Intra: all macroblock types (16x16, 8x8, and 4x4 with all predictions)
44
- Inter P: all partitions (from 16x16 down to 4x4)
45
- Inter B: partitions from 16x16 down to 8x8 (including skip/direct)
46
- Ratecontrol: constant quantizer, single or multipass ABR, optional VBV
47
- Scene cut detection
48
- Adaptive B-frame placement
49
- B-frames as references / arbitrary frame order
50
- 8x8 and 4x4 adaptive spatial transform
51
- Lossless mode
52
- Custom quantization matrices
53
- Parallel encoding of multiple slices (currently disabled)
54
55
Be aware that the x264 library is still in early development stage. The
56
command line tool x264 can handle only raw YUV 4:2:0 streams at the
57
moment so please use mencoder or another tool that supports x264 library
58
for all other file types.
59
60
%package -n %{realname}-%{soname}
61
Summary: A free h264/avc encoder - encoder binary
62
Group: Productivity/Multimedia/Video
63
64
%description -n %{realname}-%{soname}
65
x264 is a free library for encoding next-generation H264/AVC video
66
streams. The code is written from scratch by Laurent Aimar, Loren
67
Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans
68
Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and
69
Alex Wright. It is released under the terms of the GPL license. This
70
package contains a static library and a header needed for the
71
development with libx264. This library is needed to build
72
mplayer/mencoder with H264 encoding support.
73
74
75
%package -n %{realname}-%{sonamecompa}
76
Summary: A free h264/avc encoder - encoder binary
77
Group: Productivity/Multimedia/Video
78
79
%description -n %{realname}-%{sonamecompa}
80
x264 is a free library for encoding next-generation H264/AVC video
81
streams. The code is written from scratch by Laurent Aimar, Loren
82
Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans
83
Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and
84
Alex Wright. It is released under the terms of the GPL license. This
85
package contains a static library and a header needed for the
86
development with libx264. This library is needed to build
87
mplayer/mencoder with H264 encoding support.
88
89
90
%package -n %{realname}-%{sonamecompb}
91
Summary: A free h264/avc encoder - encoder binary
92
Group: Productivity/Multimedia/Video
93
94
%description -n %{realname}-%{sonamecompb}
95
x264 is a free library for encoding next-generation H264/AVC video
96
streams. The code is written from scratch by Laurent Aimar, Loren
97
Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans
98
Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and
99
Alex Wright. It is released under the terms of the GPL license. This
100
package contains a static library and a header needed for the
101
development with libx264. This library is needed to build
102
mplayer/mencoder with H264 encoding support.
103
104
105
%package -n %{realname}-%{sonamecompc}
106
Summary: A free h264/avc encoder - encoder binary
107
Group: Productivity/Multimedia/Video
108
109
%description -n %{realname}-%{sonamecompc}
110
x264 is a free library for encoding next-generation H264/AVC video
111
streams. The code is written from scratch by Laurent Aimar, Loren
112
Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans
113
Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and
114
Alex Wright. It is released under the terms of the GPL license. This
115
package contains a static library and a header needed for the
116
development with libx264. This library is needed to build
117
mplayer/mencoder with H264 encoding support.
118
119
120
%package -n %{realname}-devel
121
Summary: Libraries and include file for the x264 encoder.
122
Group: Development/Libraries/C and C++
123
Requires: %{realname}-%{soname} = %{version}-%{release}
124
Requires: %{buildrequires}
125
Obsoletes: x264-devel < %{version}-%{release}
126
Provides: x264-devel = %{version}-%{release}
127
128
%description -n %{realname}-devel
129
x264 is a free library for encoding next-generation H264/AVC video
130
streams. The code is written from scratch by Laurent Aimar, Loren
131
Merritt, Eric Petit (OS X), Min Chen (vfw/asm), Justin Clay (vfw), Mans
132
Rullgard, Radek Czyz, Christian Heine (asm), Alex Izvorski (asm), and
133
Alex Wright. It is released under the terms of the GPL license. This
134
package contains a static library and a header needed for the
135
development with libx264. This library is needed to build
136
mplayer/mencoder with H264 encoding support.
137
138
%debug_package
139
140
%prep
141
%setup -q -n "x264-snapshot-%{svn}-2245" -b 1 -b 2 -b 3
142
143
%build
144
%ifarch i586
145
#no mmx or sse on the i586 package, therefore use i686 package, should run on every i586 cpu
146
%configure --enable-shared --enable-pic --disable-asm
147
%else
148
%configure --enable-shared --enable-pic
149
%endif
150
%__make %{?jobs:-j%{jobs}}
151
152
cd ../x264-snapshot-%{svncompa}-2245
153
%ifarch i586
154
#no mmx or sse on the i586 package, therefore use i686 package, should run on every i586 cpu
155
%configure --enable-shared --enable-pic --disable-asm
156
%else
157
%configure --enable-shared --enable-pic
158
%endif
159
%__make %{?jobs:-j%{jobs}}
160
161
cd ../x264-snapshot-%{svncompb}-2245
162
%ifarch i586
163
#no mmx or sse on the i586 package, therefore use i686 package, should run on every i586 cpu
164
%configure --enable-shared --enable-pic --disable-asm
165
%else
166
%configure --enable-shared --enable-pic
167
%endif
168
%__make %{?jobs:-j%{jobs}}
169
170
cd ../x264-snapshot-%{svncompc}-2245
171
%ifarch i586
172
#no mmx or sse on the i586 package, therefore use i686 package, should run on every i586 cpu
173
%configure --enable-shared --enable-pic --disable-asm
174
%else
175
%configure --enable-shared --enable-pic
176
%endif
177
%__make %{?jobs:-j%{jobs}}
178
179
%install
180
%makeinstall
181
182
%__rm -f "%{buildroot}/%{_libdir}/libx264.so"
183
%__ln_s libx264.so.%{soname} "%{buildroot}%{_libdir}/libx264.so"
184
185
cd ../x264-snapshot-%{svncompa}-2245
186
%{__install} -m 644 libx264.so.%{sonamecompa} %{buildroot}%{_libdir}/
187
188
cd ../x264-snapshot-%{svncompb}-2245
189
%{__install} -m 644 libx264.so.%{sonamecompb} %{buildroot}%{_libdir}/
190
191
cd ../x264-snapshot-%{svncompc}-2245
192
%{__install} -m 644 libx264.so.%{sonamecompc} %{buildroot}%{_libdir}/
193
194
%clean
195
%__rm -rf "%{buildroot}"
196
197
%post -n %{realname}-%{soname} -p /sbin/ldconfig
198
%postun -n %{realname}-%{soname} -p /sbin/ldconfig
199
200
%post -n %{realname}-%{sonamecompa} -p /sbin/ldconfig
201
%postun -n %{realname}-%{sonamecompa} -p /sbin/ldconfig
202
203
%post -n %{realname}-%{sonamecompb} -p /sbin/ldconfig
204
%postun -n %{realname}-%{sonamecompb} -p /sbin/ldconfig
205
206
%post -n %{realname}-%{sonamecompc} -p /sbin/ldconfig
207
%postun -n %{realname}-%{sonamecompc} -p /sbin/ldconfig
208
209
%files
210
%defattr(-,root,root)
211
%doc doc/*.txt
212
%attr(0755,root,root) %{_bindir}/x264
213
214
%files -n %{realname}-%{soname}
215
%defattr(0644,root,root)
216
%attr(0755,root,root) %{_libdir}/libx264.so.%{soname}
217
218
%files -n %{realname}-%{sonamecompa}
219
%defattr(0644,root,root)
220
%attr(0755,root,root) %{_libdir}/libx264.so.%{sonamecompa}
221
222
%files -n %{realname}-%{sonamecompb}
223
%defattr(0644,root,root)
224
%attr(0755,root,root) %{_libdir}/libx264.so.%{sonamecompb}
225
226
%files -n %{realname}-%{sonamecompc}
227
%defattr(0644,root,root)
228
%attr(0755,root,root) %{_libdir}/libx264.so.%{sonamecompc}
229
230
%files -n %{realname}-devel
231
%defattr(0644,root,root)
232
%{_libdir}/pkgconfig/x264.pc
233
%{_includedir}/x264.h
234
%{_libdir}/libx264.so
235
%{_libdir}/libx264.a
236
237
%changelog
238
* Mon Jun 29 2009 Carsten Schoene <cs@linux-administrator.com> - 20090627-15
239
- import for SLE_11 build
240