File SDL_image.spec of Package SDL_image (Revision 2)
Currently displaying revision 2, show latest
1
#
2
# spec file for package SDL_image (Version 1.2.4)
3
#
4
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
# This file and all modifications and additions to the pristine
6
# package are under the same license as the package itself.
7
#
8
# Please submit bugfixes or comments via http://bugs.opensuse.org/
9
#
10
11
# norootforbuild
12
# usedforbuild SDL SDL-devel aaa_base aalib aalib-devel acl alsa alsa-devel attr audit-libs autoconf automake bash bind-libs bind-utils binutils bison bzip2 coreutils cpio cpp cracklib cvs cyrus-sasl db diffutils e2fsprogs expat file filesystem fillup findutils flex fontconfig fontconfig-devel gawk gcc gdbm gdbm-devel gettext gettext-devel glibc glibc-32bit glibc-devel glibc-locale gpm grep groff gzip info insserv klogd less libacl libattr libcom_err libgcc libjpeg libjpeg-devel libmudflap libnscd libpng libpng-devel libstdc++ libstdc++-devel libtiff libtiff-devel libtool libxcrypt libzio m4 make man mktemp module-init-tools ncurses ncurses-devel net-tools netcfg openldap2-client openssl pam pam-modules patch perl permissions popt procinfo procps psmisc pwdutils rcs readline resmgr rpm sed slang slang-devel strace sysvinit tar tcpd texinfo timezone unzip util-linux vim xorg-x11 xorg-x11-devel xorg-x11-libs zlib zlib-devel
13
14
Name: SDL_image
15
BuildRequires: SDL-devel libjpeg-devel libpng-devel libtiff-devel xorg-x11
16
Url: http://www.libsdl.org/projects/SDL_image/
17
Summary: Simple DirectMedia Layer--Sample Image Loading Library
18
Version: 1.2.4
19
Release: 16.8
20
Source0: %{name}-%{version}.tar.bz2
21
Patch0: %{name}-%{version}-gif-overflow.patch
22
Patch1: %{name}-%{version}-lbm-overflow.patch
23
License: LGPL v2.1 or later
24
Group: System/Libraries
25
BuildRoot: %{_tmppath}/%{name}-%{version}-build
26
Prefix: %{_prefix}
27
28
%description
29
This is a simple library to load images of various formats as SDL
30
surfaces. This library supports BMP, PPM, PCX, GIF, JPEG, PNG, and TIFF
31
formats.
32
33
34
35
Authors:
36
--------
37
Sam Lantinga <slouken@devolution.com>
38
39
%debug_package
40
%package devel
41
Summary: Libraries, includes and more to develop SDL_image applications
42
Group: Development/Libraries/X11
43
Requires: %{name} SDL-devel libjpeg-devel libpng-devel libstdc++-devel gcc gpm
44
45
%description devel
46
This is a simple library to load images of various formats as SDL
47
surfaces. This library supports BMP, PPM, PCX, GIF, JPEG, PNG, and TIFF
48
formats.
49
50
51
52
Authors:
53
--------
54
Sam Lantinga <slouken@devolution.com>
55
56
%prep
57
rm -rf ${RPM_BUILD_ROOT}
58
%setup
59
%patch0
60
%patch1
61
62
%build
63
%{?suse_update_config:%{suse_update_config -f }}
64
rm acinclude.m4 ; touch acinclude.m4 # Only contains SDL.m4 and libtool.m4
65
libtoolize --copy --force
66
aclocal
67
autoconf
68
CFLAGS="$RPM_OPT_FLAGS" ./configure \
69
--prefix=%{prefix} \
70
--libdir=%{prefix}/%_lib
71
make
72
73
%install
74
rm -rf $RPM_BUILD_ROOT
75
make install DESTDIR=$RPM_BUILD_ROOT
76
77
%post
78
%run_ldconfig
79
80
%postun
81
%run_ldconfig
82
83
%clean
84
rm -rf $RPM_BUILD_ROOT
85
86
%files
87
%defattr(-,root,root)
88
%doc README CHANGES COPYING
89
%{prefix}/%_lib/lib*.so.*
90
91
%files devel
92
%defattr(-,root,root)
93
%{prefix}/%_lib/*a
94
%{prefix}/include/SDL/
95
%{prefix}/%_lib/lib*.so
96
97
%changelog
98
* Sat Feb 02 2008 Carsten Schoene <cs@linux-administrator.com>
99
- import for SLE_10 build
100
101
* Tue Jan 29 2008 - prusnak@suse.cz
102
- fix buffer overflow in LBM code (lbm-overflow.patch) [#355864]
103
* Fri Jan 25 2008 - prusnak@suse.cz
104
- fix buffer overflow in GIF code (gif-overflow.patch) [#355864]
105
* Fri Mar 10 2006 - bk@suse.de
106
- SDL_image-devel: add libstdc++, gcc and gpm to Requires (.la check)
107
* Mon Jan 30 2006 - coolo@suse.de
108
- fixing BuildRequires to include png support
109
* Wed Jan 25 2006 - mls@suse.de
110
- converted neededforbuild to BuildRequires
111
* Tue Jul 19 2005 - nadvornik@suse.cz
112
- updated to 1.2.4
113
* Sat Jan 10 2004 - adrian@suse.de
114
- add %%run_ldconfig
115
* Fri Jul 25 2003 - nadvornik@suse.cz
116
- update to 1.2.3
117
* Wed Jul 03 2002 - nadvornik@suse.cz
118
- updated to 1.2.2
119
* Tue Jun 11 2002 - meissner@suse.de
120
- regenerate auto files, removed acinclude.m4 (which only contains
121
SDL.m4 and libtool.m4).
122
* Fri May 10 2002 - ro@suse.de
123
- libdir fixed
124
* Fri Feb 01 2002 - ro@suse.de
125
- changed neededforbuild <libpng> to <libpng-devel-packages>
126
* Tue Jan 22 2002 - ro@suse.de
127
- changed neededforbuild <kdelibs-artsd> to <kdelibs3-artsd>
128
* Tue Jan 08 2002 - nadvornik@suse.cz
129
- updated to 1.2.1:
130
- added LBM format
131
- fixed transparent GIF and PNG
132
* Wed Aug 08 2001 - uli@suse.de
133
- fixed neededforbuild wrt SDL renaming
134
* Wed Jun 20 2001 - nadvornik@suse.cz
135
- added kdelibs and kdelibs-devel to neededforbuild
136
* Thu Apr 12 2001 - nadvornik@suse.cz
137
- update to 1.2.0
138
* Mon Mar 26 2001 - ro@suse.de
139
- changed neededforbuild <sdl> to <sdl sdl-devel>
140
* Mon Feb 19 2001 - uli@suse.de
141
- added alsa* to neededforbuild (needed by new SDL)
142
* Tue Dec 05 2000 - nadvornik@suse.cz
143
- added suse_update_config
144
* Tue Nov 28 2000 - nadvornik@suse.cz
145
- new package
146