Logoj0ke.net Open Build Service > Projects > internetx:projects:virtualization > libvirt-sandbox > libvirt-sandbox.spec
Sign Up | Log In

File libvirt-sandbox.spec of Package libvirt-sandbox (Revision 2)

Currently displaying revision 2, show latest

 
1
# -*- rpm-spec -*-
2
3
%define with_qemu 1
4
5
# RHEL does not provide the 9p.ko kernel module
6
# nor the virtio-9p KVM backend driver.
7
%if 0%{?rhel}
8
%define with_qemu 0
9
%endif
10
11
%define libvirt_version 1.0.2
12
13
14
Name: libvirt-sandbox
15
Version: 0.5.1
16
Release: 4%{?dist}%{?extra_release}
17
Summary: libvirt application sandbox framework
18
Group: Development/Tools
19
License: LGPLv2+
20
URL: http://libvirt.org/
21
Source0: ftp://libvirt.org/libvirt/sandbox/%{name}-%{version}.tar.gz
22
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
23
BuildRequires: libvirt-gobject-devel >= 0.1.7
24
BuildRequires: gobject-introspection-devel
25
BuildRequires: glibc-static
26
BuildRequires: intltool
27
BuildRequires: libselinux-devel
28
BuildRequires: glib2-devel >= 2.32.0
29
Requires: rpm-python
30
# For virsh lxc-enter-namespace command
31
Requires: libvirt-client >= %{libvirt_version}
32
Requires: systemd >= 198
33
Requires: pygobject3-base
34
Requires: libselinux-python
35
Requires: %{name}-libs = %{version}-%{release}
36
37
%package libs
38
Group: Development/Libraries
39
Summary: libvirt application sandbox framework libraries
40
# So we get the full libvirtd daemon, not just client libs
41
%if %{with_qemu}
42
 %ifarch %{ix86} x86_64
43
Requires: libvirt-daemon-kvm >= %{libvirt_version}
44
 %else
45
Requires: libvirt-daemon-qemu >= %{libvirt_version}
46
 %endif
47
%endif
48
Requires: libvirt-daemon-lxc >= %{libvirt_version}
49
50
%package devel
51
Group: Development/Libraries
52
Summary: libvirt application sandbox framework development files
53
Requires: %{name}-libs = %{version}-%{release}
54
55
%description
56
This package provides a command for running applications within
57
a sandbox using libvirt.
58
59
%description libs
60
This package provides a framework for building application sandboxes
61
using libvirt.
62
63
%description devel
64
This package provides development header files and libraries for
65
the libvirt sandbox
66
67
%prep
68
%setup -q
69
70
%build
71
72
%configure --enable-introspection
73
%__make %{?_smp_mflags}
74
75
76
%install
77
rm -rf $RPM_BUILD_ROOT
78
chmod a-x examples/*.py examples/*.pl examples/*.js
79
%__make install  DESTDIR=$RPM_BUILD_ROOT
80
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-sandbox-1.0.a
81
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-sandbox-1.0.la
82
83
%find_lang %{name}
84
85
%clean
86
rm -rf $RPM_BUILD_ROOT
87
88
%post libs -p /sbin/ldconfig
89
%postun libs -p /sbin/ldconfig
90
91
%files
92
%defattr(-,root,root,-)
93
%{_datadir}/bash-completion/completions/virt-sandbox-service
94
%config(noreplace) %{_sysconfdir}/cron.daily/virt-sandbox-service.logrotate
95
%dir %{_sysconfdir}/libvirt-sandbox/services
96
%{_bindir}/virt-sandbox
97
%{_bindir}/virt-sandbox-service
98
%{_libexecdir}/virt-sandbox-service-util
99
%{_mandir}/man1/virt-sandbox.1*
100
%{_mandir}/man1/virt-sandbox-service.1*
101
%{_mandir}/man1/virt-sandbox-service-*.1*
102
103
%files libs -f %{name}.lang
104
%defattr(-,root,root,-)
105
%doc README COPYING AUTHORS ChangeLog NEWS
106
%dir %{_sysconfdir}/libvirt-sandbox
107
%dir %{_sysconfdir}/libvirt-sandbox/scratch
108
%config %{_sysconfdir}/libvirt-sandbox/scratch/README
109
%{_libexecdir}/libvirt-sandbox-init-common
110
%{_libexecdir}/libvirt-sandbox-init-lxc
111
%{_libexecdir}/libvirt-sandbox-init-qemu
112
%{_libdir}/libvirt-sandbox-1.0.so.*
113
%{_libdir}/girepository-1.0/LibvirtSandbox-1.0.typelib
114
115
%files devel
116
%defattr(-,root,root,-)
117
%doc examples/virt-sandbox.pl
118
%doc examples/virt-sandbox.py
119
%doc examples/virt-sandbox.js
120
%doc examples/virt-sandbox-mkinitrd.py
121
%{_libdir}/libvirt-sandbox-1.0.so
122
%{_libdir}/pkgconfig/libvirt-sandbox-1.0.pc
123
%dir %{_includedir}/libvirt-sandbox-1.0
124
%dir %{_includedir}/libvirt-sandbox-1.0/libvirt-sandbox
125
%{_includedir}/libvirt-sandbox-1.0/libvirt-sandbox/libvirt-sandbox.h
126
%{_includedir}/libvirt-sandbox-1.0/libvirt-sandbox/libvirt-sandbox-*.h
127
%{_datadir}/gir-1.0/LibvirtSandbox-1.0.gir
128
%{_datadir}/gtk-doc/html/Libvirt-sandbox
129
130
%changelog
131
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-4
132
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
133
134
* Tue Jul 22 2014 Kalev Lember <kalevlember@gmail.com> - 0.5.1-3
135
- Rebuilt for gobject-introspection 1.41.4
136
137
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
138
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
139
140
* Mon Nov 18 2013 Daniel P. Berrange <berrange@redhat.com> - 0.5.1-1
141
- Update to 0.5.0 release
142
143
* Thu Oct  3 2013 Daniel P. Berrange <berrange@redhat.com> - 0.5.0-3
144
- Add fully versioned dep between libvirt-sandbox & libvirt-sandbox-libs
145
146
* Tue Oct  1 2013 Daniel P. Berrange <berrange@redhat.com> - 0.5.0-2
147
- Fix boot with Linux 3.11 kernel
148
149
* Thu Aug  1 2013 Daniel P. Berrange <berrange@redhat.com> - 0.5.0-1
150
- Update to 0.5.0 release
151
152
* Tue Jul  9 2013 Daniel P. Berrange <berrange@redhat.com> - 0.2.1-1
153
- Update to 0.2.1 release
154
155
* Tue May  7 2013 Daniel P. Berrange <berrange@redhat.com> - 0.2.0-1
156
- Update to 0.2.0 release
157
158
* Tue Mar  5 2013 Daniel P. Berrange <berrange@redhat.com> - 0.1.2-1
159
- Update to 0.1.2 release
160
161
* Fri Feb 22 2013 Daniel P. Berrange <berrange@redhat.com> - 0.1.1-4
162
- Add dep on pod2man
163
164
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
165
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
166
167
* Thu Jan 17 2013 Daniel P. Berrange <berrange@redhat.com> - 0.1.1-2
168
- Conditionalize dep on libvirt-daemon-qemu
169
170
* Mon Dec 10 2012 Daniel P. Berrange <berrange@redhat.com> - 0.1.1-1
171
- Update to 0.1.1 release
172
173
* Mon Aug 13 2012 Daniel P. Berrange <berrange@redhat.com> - 0.1.0-1
174
- Update to 0.1.0 release
175
176
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.3-3
177
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
178
179
* Fri Apr 27 2012 Daniel P. Berrange <berrange@redhat.com> - 0.0.3-2
180
- Rebuild for libvirt-gobject update
181
182
* Fri Apr 13 2012 Daniel P. Berrange <berrange@redhat.com> - 0.0.3-1
183
- Update to 0.0.3 release
184
185
* Thu Jan 12 2012 Daniel P. Berrange <berrange@redhat.com> - 0.0.2-1
186
- Update to 0.0.2 release
187
188
* Wed Jan 11 2012 Daniel P. Berrange <berrange@redhat.com> - 0.0.1-1
189
- Initial package
190
191