Logoj0ke.net Open Build Service > Projects > internetx:php5:5.6.24:extensions > php5-xcache > php5-xcache.spec
Sign Up | Log In

File php5-xcache.spec of Package php5-xcache

x
 
1
# norootforbuild
2
%define pkg_name    xcache
3
%define php_version %(php-config --version 2>/dev/null)
4
#
5
Name:       php5-xcache
6
Version:    3.2.0
7
Release:    1
8
License:    BSD 
9
Group:      Productivity/Networking/Web/Servers
10
BuildRoot:  %{_tmppath}/%{name}-%{version}-build
11
BuildRequires:  php5-devel >= 5.1 indent
12
Requires:   php5 = %{php_version} 
13
Provides:   php5_code_cache
14
Conflicts:  php5-APC php5-eaccelerator
15
%if 0%{?suse_version} > 1000
16
Enhances:   php5
17
%endif
18
#
19
URL:        http://xcache.lighttpd.net/
20
Source:     http://xcache.lighttpd.net/pub/Releases/%{version}/%{pkg_name}-%{version}.tar.bz2
21
Patch0:     xcache-broken-%{version}.ini.patch
22
#
23
Summary: A fast, stable php opcode cacher
24
25
%description
26
XCache is a fast, stable php opcode cacher that has been tested and now running
27
on production server under high load. It support and is tested on all lastest
28
php cvs branches, such as PHP_4_3 PHP_4_4 PHP_5_1 PHP_5_2 PHP_5_3 PHP_5_4 HEAD(6.x)
29
30
31
Authors:
32
---------
33
    moo <phpxcache@gmail.com>
34
35
%prep
36
%setup -q -n %{pkg_name}-%{version}
37
%patch0
38
39
%{__mkdir} %{name}
40
41
%build
42
/usr/bin/phpize
43
44
CFLAGS="%{optflags} -fno-strict-aliasing"
45
%if 0%{?suse_version} > 1000
46
CFLAGS="$CFLAGS -fstack-protector"
47
%endif
48
49
export CFLAGS
50
51
./configure \
52
    --enable-xcache \
53
    --enable-xcache-coverager
54
%{__make} %{?jobs:-j%jobs}
55
56
%install
57
%__make install INSTALL_ROOT=%{buildroot}
58
%{__install} -D  -m 0644 xcache.ini %{buildroot}%{_sysconfdir}/php5/conf.d/xcache.ini
59
%{__install} -Dd -m 0755 %{buildroot}%{_datadir}/php5/xcache/
60
touch htdocs/{,coverager}/config.php
61
%{__cp} -rv htdocs/* %{buildroot}%{_datadir}/php5/xcache/
62
63
%clean
64
%{__rm} -rf %{buildroot}
65
66
%files
67
%defattr(644,root,root,755)
68
%{_libdir}/php5/extensions/xcache.so
69
%config(noreplace) %{_sysconfdir}/php5/conf.d/xcache.ini
70
%dir %{_datadir}/php5/xcache/
71
%dir %{_datadir}/php5/xcache/cacher
72
%dir %{_datadir}/php5/xcache/cacher/lang
73
%dir %{_datadir}/php5/xcache/cacher/sub
74
%dir %{_datadir}/php5/xcache/common
75
%dir %{_datadir}/php5/xcache/common/lang
76
%dir %{_datadir}/php5/xcache/coverager
77
%dir %{_datadir}/php5/xcache/coverager/lang
78
%dir %{_datadir}/php5/xcache/diagnosis
79
%dir %{_datadir}/php5/xcache/diagnosis/lang
80
%ghost %config(noreplace) %{_datadir}/php5/xcache/config.php
81
%ghost %config(noreplace) %{_datadir}/php5/xcache/coverager/config.php
82
%{_datadir}/php5/xcache/config.example.php                                                                     
83
%{_datadir}/php5/xcache/diagnosis/lang/zh-tranditional.php                                                     
84
%{_datadir}/php5/xcache/diagnosis/lang/zh-traditional.po                                                       
85
%{_datadir}/php5/xcache/diagnosis/lang/zh-simplified.po                                                        
86
%{_datadir}/php5/xcache/diagnosis/lang/zh-traditional.php                                                      
87
%{_datadir}/php5/xcache/diagnosis/lang/zh-simplified.php                                                       
88
%{_datadir}/php5/xcache/diagnosis/lang/en.po                                                                   
89
%{_datadir}/php5/xcache/diagnosis/lang/en.php                                                                  
90
%{_datadir}/php5/xcache/diagnosis/diagnosis.css                                                                
91
%{_datadir}/php5/xcache/diagnosis/diagnosis.tpl.php                                                            
92
%{_datadir}/php5/xcache/diagnosis/index.php                                                                    
93
%{_datadir}/php5/xcache/config.default.php                                                                     
94
%{_datadir}/php5/xcache/cacher/edit.php                                                                        
95
%{_datadir}/php5/xcache/cacher/lang/zh-traditional.po                                                          
96
%{_datadir}/php5/xcache/cacher/lang/zh-simplified.po                                                           
97
%{_datadir}/php5/xcache/cacher/lang/zh-traditional.php                                                         
98
%{_datadir}/php5/xcache/cacher/lang/zh-simplified.php                                                          
99
%{_datadir}/php5/xcache/cacher/lang/en.po                                                                      
100
%{_datadir}/php5/xcache/cacher/lang/en.php                                                                     
101
%{_datadir}/php5/xcache/cacher/common.php                                                                      
102
%{_datadir}/php5/xcache/cacher/config.example.php
103
%{_datadir}/php5/xcache/cacher/config.default.php
104
%{_datadir}/php5/xcache/cacher/edit.tpl.php
105
%{_datadir}/php5/xcache/cacher/cacher.css
106
%{_datadir}/php5/xcache/cacher/summary.tpl.php
107
%{_datadir}/php5/xcache/common/tablesort.js
108
%{_datadir}/php5/xcache/cacher/index.php
109
%{_datadir}/php5/xcache/cacher/mkpassword.php
110
%{_datadir}/php5/xcache/cacher/sub/testcoredump.tpl.php
111
%{_datadir}/php5/xcache/cacher/sub/entrylist.tpl.php
112
%{_datadir}/php5/xcache/cacher/sub/summary.tpl.php
113
%{_datadir}/php5/xcache/cacher/sub/moduleinfo.tpl.php
114
%{_datadir}/php5/xcache/cacher/listentries.tpl.php
115
%{_datadir}/php5/xcache/common/common.css
116
%{_datadir}/php5/xcache/common/lang/zh-traditional.po
117
%{_datadir}/php5/xcache/common/lang/zh-simplified.po
118
%{_datadir}/php5/xcache/common/lang/zh-traditional.php
119
%{_datadir}/php5/xcache/common/lang/zh-simplified.php
120
%{_datadir}/php5/xcache/common/lang/en.po
121
%{_datadir}/php5/xcache/common/lang/en.php
122
%{_datadir}/php5/xcache/common/xcache.png
123
%{_datadir}/php5/xcache/common/common.php
124
%{_datadir}/php5/xcache/common/header.tpl.php
125
%{_datadir}/php5/xcache/common/footer.tpl.php
126
%{_datadir}/php5/xcache/index.php
127
%{_datadir}/php5/xcache/coverager/lang/zh-traditional.po
128
%{_datadir}/php5/xcache/coverager/lang/zh-simplified.po
129
%{_datadir}/php5/xcache/coverager/lang/zh-traditional.php
130
%{_datadir}/php5/xcache/coverager/lang/zh-simplified.php
131
%{_datadir}/php5/xcache/coverager/lang/en.po
132
%{_datadir}/php5/xcache/coverager/lang/en.php
133
%{_datadir}/php5/xcache/coverager/common.php
134
%{_datadir}/php5/xcache/coverager/config.example.php
135
%{_datadir}/php5/xcache/coverager/config.default.php
136
%{_datadir}/php5/xcache/coverager/index.php
137
%{_datadir}/php5/xcache/coverager/coverager.css
138
%{_datadir}/php5/xcache/coverager/coverager.tpl.php
139
%doc AUTHORS COPYING NEWS THANKS
140
141
%changelog
142
* Mon Nov 29 2010 Carsten Schoene <cs@linux-administrator.com> - 1.3.1
143
- update to release 1.3.1
144
145
* Sat Aug 08 2009 Carsten Schoene <cs@linux-administrator.com> - 1.3.0
146
- update to release 1.3.0
147
148
* Mon Dec 11 2006 - judas_iscariote@shorewall.net
149
- Update to 1.2.0 final.
150
* Wed Oct 11 2006 - soporte@onfocus.cl
151
- Update package name to 1.2dev, currenly running OK in php 5.2
152
* Mon Sep 18 2006 - soporte@onfocus.cl
153
- update snapshot and add missing files
154
* Thu Aug 08 2006 - soporte@onfocus.cl
155
- License is BSD not GPL
156
- update to current svn and include the revision name in the package name
157
* Thu Jul 27 2006 - soporte@onfocus.cl
158
- updated to current SVN to make it work under PHP 5.2
159
* Thu Jul 11 2006 - soporte@onfocus.cl
160
- Enable var_cache and safer read only protection
161
* Sun Jul 2 2006 - soporte@onfocus.cl
162
- xcache-broken-ini.patch updated again..
163
* Fri Jun 9 2006 - soporte@onfocus.cl
164
- xcache-broken.ini.patch make things really work...
165