Logoj0ke.net Open Build Service > Projects > internetx:php5:5.6.24:extensions > php5-mysqlnd_qc > php5-mysqlnd_qc.spec
Sign Up | Log In

File php5-mysqlnd_qc.spec of Package php5-mysqlnd_qc

x
 
1
# norootforbuild
2
%define pkg_name    mysqlnd_qc
3
%define pkg_version 1.0.1
4
%define php_version %(php-config --version 2>/dev/null)
5
#
6
Name:       php5-mysqlnd_qc
7
Version:    %{pkg_version}
8
Release:    0
9
#
10
License:    PHP
11
Group:      Productivity/Networking/Web/Servers
12
#
13
BuildRoot:  %{_tmppath}/%{pkg_name}-%{version}-build
14
BuildRequires:  gcc gcc-c++
15
BuildRequires:  php5-devel >= 5.3.4
16
BuildRequires:  libmemcached-devel
17
#BuildRequires: mysql-devel
18
BuildRequires:  sqlite-devel >= 3.0
19
Requires:   php5 = %{php_version}
20
#
21
URL:        http://pecl.php.net/
22
Source:     http://pecl.php.net/package/%{pkg_name}/%{pkg_name}-%{version}.tgz
23
Summary:    A query cache plugin for mysqlnd
24
25
%description
26
The mysqlnd query result cache plugin is a mysqlnd plugin. It adds basic client side
27
result set caching to all PHP MySQL extensions (ext/mysql, ext/mysqli, PDO_MySQL),
28
if they are compiled to use mysqlnd. It does not change the API of the MySQL extensions
29
and thus it operates virtually transparent for applications."
30
31
Authors:
32
---------
33
34
        Andrey Hristov
35
        Ulf Wendel
36
37
%debug_package
38
39
%prep
40
%setup -n %{pkg_name}-%{version}
41
42
%{__mkdir} %{name}
43
44
%build
45
/usr/bin/phpize
46
pushd %{name}
47
48
CFLAGS="%{optflags} -fno-strict-aliasing"
49
CXXFLAGS="%{optflags} -fno-strict-aliasing"
50
%if 0%{?suse_version} > 1000
51
CFLAGS="$CFLAGS -fstack-protector"
52
CXXFLAGS="$CXXFLAGS -fstack-protector"
53
%endif
54
55
export CFLAGS
56
export CXXFLAGS
57
58
../configure --with-libdir=%{_lib} \
59
 --enable-mysqlnd-qc \
60
 --enable-mysqlnd-qc-memcache \
61
 --enable-mysqlnd-qc-sqlite \
62
 --with-sqlite-dir=%{_prefix}
63
64
%{__make} %{?jobs:-j%jobs}
65
popd
66
67
%install
68
%makeinstall -C %{name} INSTALL_ROOT=%{buildroot}
69
%{__mkdir} -p %{buildroot}%{_sysconfdir}/php5/conf.d
70
echo "; comment out next line to disable mysqlnd_qc extension in php" > %{buildroot}%{_sysconfdir}/php5/conf.d/mysqlnd_qc.ini
71
echo "extension = mysqlnd_qc.so" >> %{buildroot}%{_sysconfdir}/php5/conf.d/mysqlnd_qc.ini
72
73
74
%clean
75
%{__rm} -rf %{buildroot}
76
77
%files
78
%defattr(-,root,root,-)
79
%{_libdir}/php5/extensions/mysqlnd_qc.so
80
%config(noreplace) %{_sysconfdir}/php5/conf.d/mysqlnd_qc.ini
81
82
%changelog
83
* Mon Dec 06 2010 Carsten Schoene <cs@linux-administrator.com> - 1.0.1-1
84
- update to version 1.0.1 stable
85
86
* Fri Oct 15 2010 Carsten Schoene <cs@linux-administrator.com> - 1.0.0-1
87
- initial build version 1.0.0 beta
88