File libvirt-php.spec of Package php5-libvirt
x
1
%define req_libvirt_version 0.9.3
2
%define pkgname libvirt-php
3
%if 0%{?suse_version}
4
%define php_confdir %{_sysconfdir}/php5/conf.d
5
%define php_extdir %{_libdir}/php5/extensions
6
%define pkg_name php5-libvirt
7
%else
8
%define php_confdir %{_sysconfdir}/php.d
9
%define php_extdir %{_libdir}/php/modules
10
%define pkg_name php-libvirt
11
%endif
12
13
Name: %{pkg_name}
14
Version: 0.4.8
15
Release: 3%{?dist}%{?extra_release}
16
Summary: PHP language binding for Libvirt
17
18
%if 0%{?suse_version}
19
Group: Development/Libraries/PHP
20
%else
21
Group: Development/Libraries
22
%endif
23
License: PHP
24
URL: http://libvirt.org/php
25
Source0: http://libvirt.org/sources/php/libvirt-php-%{version}.tar.bz2
26
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27
BuildRequires: -post-build-checks
28
BuildRequires: libvirt-devel >= %{req_libvirt_version}
29
BuildRequires: libxml2-devel
30
BuildRequires: libxslt
31
%if 0%{?suse_version}
32
BuildRequires: xhtml-dtd
33
BuildRequires: php5-devel
34
%else
35
BuildRequires: xhtml1-dtds
36
BuildRequires: php-devel
37
%endif
38
Requires: libvirt >= %{req_libvirt_version}
39
%if 0%{?suse_version}
40
Requires: php5
41
%else
42
Requires: php
43
%endif
44
45
%description
46
PHP language bindings for Libvirt API.
47
For more details see: http://www.libvirt.org/php/
48
49
%package -n libvirt-php-doc
50
Summary: Document of libvirt-php
51
Group: Development/Libraries/PHP
52
Requires: libvirt-php = %{version}
53
54
%description -n libvirt-php-doc
55
PHP language bindings for Libvirt API.
56
For more details see: http://www.libvirt.org/php/ http://www.php.net/
57
58
This package contain the document for libvirt-php.
59
60
%prep
61
%setup -q -n libvirt-php-%{version}
62
63
%build
64
%configure
65
CFLAGS="$RPM_OPT_FLAGS" CPPFLAGS="$RPM_OPT_FLAGS" ./configure --with-html-dir=%{_datadir}/doc --with-html-subdir=%{name}-%{version}/html --libdir=%{php_extdir}
66
make %{?_smp_mflags}
67
68
%install
69
rm -rf %{buildroot}
70
make install DESTDIR=%{buildroot}
71
chmod +x %{buildroot}%{php_extdir}/libvirt-php.so
72
73
%clean
74
rm -rf %{buildroot}
75
76
%files
77
%defattr(-,root,root,-)
78
%{php_extdir}/libvirt-php.so
79
%config(noreplace) %{php_confdir}/libvirt-php.ini
80
81
%files -n libvirt-php-doc
82
%defattr(-,root,root,-)
83
%doc
84
%dir %{_datadir}/doc/%{name}-%{version}
85
%{_datadir}/doc/%{name}-%{version}/html
86
87
%changelog
88