File php5-inotify.spec of Package php5-inotify
x
1
# norootforbuild
2
%define pkg_name inotify
3
%define pkg_version 0.1.6
4
%define php_version %(php-config --version 2>/dev/null)
5
#
6
Name: php5-inotify
7
Version: %{pkg_version}
8
Release: 0
9
#
10
License: PHP
11
Group: Productivity/Networking/Web/Servers
12
#
13
BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-build
14
BuildRequires: php5-devel gcc gcc-c++
15
Requires: php5 = %{php_version}
16
#
17
URL: http://pecl.php.net/
18
Source: http://pecl.php.net/package/%{pkg_name}/%{pkg_name}-%{version}.tgz
19
Patch0: inotify-%{version}.patch
20
Summary: The inotify extension allows to use inotify functions in a PHP script
21
22
%description
23
The inotify extension allows to use inotify functions in a PHP script.
24
Authors:
25
---------
26
27
Arnaud Le Blanc
28
29
%debug_package
30
31
%prep
32
%setup -n %{pkg_name}-%{version}
33
%patch0
34
35
%{__mkdir} %{name}
36
37
%build
38
/usr/bin/phpize
39
pushd %{name}
40
41
CFLAGS="%{optflags} -fno-strict-aliasing"
42
CXXFLAGS="%{optflags} -fno-strict-aliasing"
43
%if 0%{?suse_version} > 1000
44
CFLAGS="$CFLAGS -fstack-protector"
45
CXXFLAGS="$CXXFLAGS -fstack-protector"
46
%endif
47
48
export CFLAGS
49
export CXXFLAGS
50
51
../configure --with-inotify=%{_usr} --with-libdir=%{_lib}
52
53
%{__make} %{?jobs:-j%jobs}
54
popd
55
56
%install
57
%makeinstall -C %{name} INSTALL_ROOT=%{buildroot}
58
%{__mkdir} -p %{buildroot}%{_sysconfdir}/php5/conf.d
59
echo "; comment out next line to disable inotify extension in php" > %{buildroot}%{_sysconfdir}/php5/conf.d/inotify.ini
60
echo "extension = inotify.so" >> %{buildroot}%{_sysconfdir}/php5/conf.d/inotify.ini
61
62
63
%clean
64
%{__rm} -rf %{buildroot}
65
66
%files
67
%defattr(-,root,root,-)
68
%{_libdir}/php5/extensions/inotify.so
69
%config(noreplace) %{_sysconfdir}/php5/conf.d/inotify.ini
70
71
%doc CREDITS
72
73
%changelog
74
* Sun Feb 17 2013 Carsten Schoene <cs@linux-administrator.com> - 0.1.6-1
75
- update to release 0.1.6
76
* Wed Dec 30 2009 Carsten Schoene <cs@linux-administrator.com> - 0.1.4-1
77
- initial build version 0.1.4
78