Logoj0ke.net Open Build Service > Projects > internetx:php5:5.3.5:extensions > php5-sphinx > php5-sphinx.spec
Sign Up | Log In

File php5-sphinx.spec of Package php5-sphinx

x
 
1
# norootforbuild
2
%define pkg_name    sphinx
3
%define pkg_version 1.3.3
4
%define php_version %(php-config --version 2>/dev/null)
5
#
6
Name:       php5-sphinx
7
Version:    %{pkg_version}
8
Release:    1
9
#
10
License:    PHP
11
Group:      Productivity/Networking/Web/Servers
12
#
13
BuildRoot:  %{_tmppath}/%{pkg_name}-%{version}-build
14
BuildRequires:  php5-devel libsphinxclient-devel gcc gcc-c++
15
Requires:   php5 = %{php_version}
16
#
17
URL:        http://pecl.php.net/
18
Source:     http://pecl.php.net/package/%{pkg_name}/%{pkg_name}-%{version}.tgz
19
Summary:    This extension provides bindings for libsphinxclient, client library for Sphinx
20
21
%description
22
This extension provides bindings for libsphinxclient, client library for Sphinx.
23
24
Authors:
25
---------
26
27
        Antony Dovgal 
28
29
%debug_package
30
31
%prep
32
%setup -n %{pkg_name}-%{version}
33
34
%{__mkdir} %{name}
35
36
%build
37
/usr/bin/phpize
38
pushd %{name}
39
40
CFLAGS="%{optflags} -fno-strict-aliasing"
41
CXXFLAGS="%{optflags} -fno-strict-aliasing"
42
%if 0%{?suse_version} > 1000
43
CFLAGS="$CFLAGS -fstack-protector"
44
CXXFLAGS="$CXXFLAGS -fstack-protector"
45
%endif
46
47
export CFLAGS
48
export CXXFLAGS
49
50
../configure --with-sphinx=%{_usr} --with-libdir=%{_lib}
51
52
%{__make} %{?jobs:-j%jobs}
53
popd
54
55
%install
56
%makeinstall -C %{name} INSTALL_ROOT=%{buildroot}
57
%{__mkdir} -p %{buildroot}%{_sysconfdir}/php5/conf.d
58
echo "; comment out next line to disable sphinx extension in php" > %{buildroot}%{_sysconfdir}/php5/conf.d/sphinx.ini
59
echo "extension = sphinx.so" >> %{buildroot}%{_sysconfdir}/php5/conf.d/sphinx.ini
60
61
62
%clean
63
%{__rm} -rf %{buildroot}
64
65
%files
66
%defattr(-,root,root,-)
67
%{_libdir}/php5/extensions/sphinx.so
68
%config(noreplace) %{_sysconfdir}/php5/conf.d/sphinx.ini
69
70
%doc CREDITS
71
72
%changelog
73
* Thu Apr 04 2013 Carsten Schoene <cs@linux-administrator.com> - 1.3.0-1
74
- update to release 1.3.0
75
76
* Sun Apr 09 2012 Carsten Schoene <cs@linux-administrator.com> - 1.2.0-1
77
- update to release 1.2.0
78
79
* Tue Jan 12 2010 Carsten Schoene <cs@linux-administrator.com> - 1.0.3-0
80
- update to release 1.0.3
81
 - Added support for open(), close(), status() and setOverride() available in sphinx 0.9.9 new API
82
83
* Sun Dec 20 2009 Carsten Schoene <cs@linux-administrator.com> - 1.0.2-0
84
- update to release 1.0.2
85
86
* Sat Jan 31 2009 Carsten Schoene <cs@linux-administrator.com>
87
- initial build version 1.0.0
88