File php5-eaccelerator.spec of Package php5-eaccelerator
x
1
#
2
# spec file for package php5-eaccelerator (Version 0.9.6.1)
3
#
4
# Copyright (c) 2006 SUSE LINUX Products GmbH, Nuernberg, Germany.
5
# This file and all modifications and additions to the pristine
6
# package are under the same license as the package itself.
7
#
8
# Please submit bugfixes or comments via http://bugs.opensuse.org/
9
#
10
BuildRequires: -post-build-checks
11
#norootforbuild
12
13
%define php_version %(php-config --version 2>/dev/null)
14
%define pkgversion 0.9.6.1
15
16
Name: php5-eaccelerator
17
Version: 0.9.6.1
18
Release: 1
19
Url: http://eaccelerator.net/
20
Group: Productivity/Multimedia/Video/Players
21
License: GPL
22
Summary: a free PHP accelerator, optimizer, encoder and dynamic content cache
23
Source: eaccelerator-%{pkgversion}.tar.bz2
24
Source1: eaccelerator.ini
25
Autoreqprov: on
26
BuildRequires: php5-devel
27
BuildRoot: %{_tmppath}/%{name}-%{version}-build
28
Requires: php5 = %{php_version}
29
Conflicts : php5-APC php5-xcache
30
31
%description
32
eAccelerator is a free open-source PHP accelerator, optimizer, encoder and
33
dynamic content cache. It increases the performance of PHP scripts by caching
34
them in their compiled state, so that the overhead of compiling is almost
35
completely eliminated. It also optimizes scripts to speed up their execution.
36
eAccelerator typically reduces server load and increases the speed of your
37
PHP code by 1-10 times.
38
39
%prep
40
41
%setup -q -n eaccelerator-%{pkgversion}
42
43
%build
44
45
CFLAGS="%{optflags} -fno-strict-aliasing"
46
47
%if 0%{?suse_version} > 1000
48
CFLAGS="$CFLAGS -fstack-protector"
49
%endif
50
51
/usr/bin/phpize
52
53
%configure --without-eaccelerator-encoder --without-eaccelerator-loader
54
55
%{__make} %{?jobs:-j%jobs}
56
57
%install
58
%{__make} EXTENSION_DIR=%{buildroot}/usr/%{_lib}/php5/extensions install
59
%{__mkdir_p} %{buildroot}/var/cache/php5-eaccelerator/
60
%{__mkdir_p} %{buildroot}/%{_sysconfdir}/php5/conf.d/
61
%{__cp} -a %SOURCE1 %{buildroot}/%{_sysconfdir}/php5/conf.d/
62
63
%clean
64
%{__rm} -rf %{buildroot}
65
66
%files
67
%defattr (-, root, root)
68
%doc AUTHORS COPYING ChangeLog README eaccelerator.ini control.php
69
%{_libdir}/php5/extensions/eaccelerator.so
70
%config(noreplace) %{_sysconfdir}/php5/conf.d/eaccelerator.ini
71
%attr (750, wwwrun, root) /var/cache/php5-eaccelerator
72
73
%changelog -n php5-eaccelerator
74
* Tue Sep 14 2010 Carsten Schoene <cs@linux-administrator.com> - 0.9.6.1-1
75
- update to release 0.9.6.1
76
77
* Sun Dec 20 2009 Carsten Schoene <cs@linux-administrator.com> - 0.9.5.99.1-1
78
- update to 0.9.6-rc1
79
80
* Fri Feb 16 2007 - judas_iscariote@shorewall.net
81
- add norootforbuild
82
- should require the exact php version against it was built.
83
* Thu Nov 07 2006 - soporte@onfocus.cl
84
- should conflict with APC and XCache, having both installed can lead into
85
very strange results.
86
- update to 0.9.5 final.
87
* Wed Oct 11 2006 - tsieden@suse.de
88
- initial release 0.9.5-rc1
89