File otrs.spec of Package otrs3 (Revision 9)
Currently displaying revision 9, show latest
x
1
# --
2
# This software comes with ABSOLUTELY NO WARRANTY. For details, see
3
# the enclosed file COPYING for license information (GPL). If you
4
# did not receive this file, see http://www.gnu.org/licenses/gpl.txt.
5
# --
6
#
7
Summary: The Open Ticket Request System
8
Name: otrs
9
Version: 3.0.16
10
License: GNU GENERAL PUBLIC LICENSE Version 2, June 1991
11
Group: Applications/Mail
12
URL: http://www.otrs.org/
13
14
Requires: perl perl-DBI mysql perl-libwww-perl
15
16
%if 0%{?suse_version}
17
%if 0%{?suse_version} > 1020
18
BuildRequires: fdupes
19
%endif
20
Requires: perl-GD perl-GDGraph perl-GDTextUtil perl-Net-DNS perl-Digest-MD5 apache2 apache2-mod_perl mysql-client
21
Requires: perl-Msql-Mysql-modules mysql-shared procmail
22
BuildRequires: apache2 apache2-devel pwdutils
23
PreReq: pwdutils
24
%define _apxs /usr/sbin/apxs2
25
%define _apausr wwwrun
26
%define _apagrp www
27
%define _otrsusr otrs
28
%define _otrsgrp nogroup
29
%define _initdir /etc/init.d
30
%endif
31
32
%if 0%{?fedora_version} || 0%{?centos_version} || 0%{?rhel_version}
33
Requires: perl-URI mod_perl httpd mysql mysql-server procmail
34
BuildRequires: httpd httpd-devel shadow-utils
35
PreReq: shadow-utils
36
%define _apxs /usr/sbin/apxs
37
%define _apausr apache
38
%define _apagrp apache
39
%define _otrsusr otrs
40
%define _otrsgrp apache
41
%define _initdir /etc/rc.d/init.d
42
%endif
43
44
%define _apaconfdir %(%{_apxs} -q sysconfdir)/conf.d/
45
46
Autoreqprov: on
47
Release: 1
48
Source0: %{name}-%{version}.tar.bz2
49
Patch0: %{name}-suse-init.diff
50
BuildRoot: %{_tmppath}/%{name}-%{version}-build
51
52
%description
53
The Open Ticket Request System (http://otrs.org/) is a web based ticket system.
54
55
Feedback: feedback@otrs.org
56
57
58
Authors:
59
--------
60
Carsten Gross <carsten at siski.de>
61
Christian Schoepplein <cs at otrs.de>
62
Franz Breu <breu.franz at bogen.net>
63
Fred van Dijk <fvandijk at marklin.nl>
64
Lars MueLLER <lars at m5r.de>
65
Nicolas Goralski <ngoralski at oceanet-technology.com>
66
Richard Kammermayer <rk at otrs.de>
67
Stefan Rother <sr at otrs.de>
68
Thomas Raith <tr at otrs.de>
69
Vladimir Gerdjikov <gerdjikov at gerdjikovs.net>
70
Martin Edenhofer <me at otrs.de>
71
72
OTRS is an Open source Ticket Request System with many features to manage
73
customer telephone calls and e-mails. It is distributed under the GNU
74
General Public License (GPL) and tested on Linux, Solaris, AIX, FreeBSD,
75
OpenBSD and Mac OS 10.x. Do you receive many e-mails and want to answer
76
them with a team of agents? You're going to love the OTRS!
77
78
Feature list:
79
80
Web-Interface:
81
- Agent web interface for viewing and working on all customer requests
82
- Admin web interface for changing system things
83
- Customer web interface for viewing and sending infos to the agents
84
- Webinterface with themes support
85
- Multi language support (Brazilian Portuguese, Bulgarian, Dutch, English,
86
Finnish, French, German, Italian and Spanish)
87
- customize the output templates (dtl) release independently
88
- Webinterface with attachment support
89
- easy and logical to use
90
91
Email-Interface:
92
- PGP support
93
- SMIME support
94
- MIME support (attachments)
95
- dispatching of incoming email via email addess or x-header
96
- autoresponders for customers by incoming emails (per queue)
97
- email-notification to the agent by new tickets, follow ups or lock timeouts
98
99
Ticket:
100
- custom queue view and queue view of all requests
101
- Ticket locking
102
- Ticket replies (standard responses)
103
- Ticket autoresponders per queue
104
- Ticket history, evolution of ticket status and actions taken on ticket
105
- abaility to add notes (with different note types) to a ticket
106
- Ticket zoom feature
107
- Tickets can be bounced or forwarded to other email addresses
108
- Ticket can be moved to a different queue (this is helpful if emails are
109
for a specific subject)
110
- Ticket priority
111
- Ticket time accounting
112
- Ticket merge feature
113
- Ticket ACL support
114
- content Fulltext search
115
116
System:
117
- creation and configuration of user accounts, and groups
118
- creation of standard responses
119
- Signature configuration per queue
120
- Salutation configuration per queue
121
- email-notification of administrators
122
- email-notification sent to problem reporter (by create, locked, deleted,
123
moved and closed)
124
- submitting update-info (via email or webinterface).
125
- deadlines for trouble tickets
126
- ASP (activ service providing) support
127
- TicketHook free setable like 'Call#', 'MyTicket#', 'Request#' or 'Ticket#'
128
- Ticket number format free setable
129
- different levels of permissions/access-rights.
130
- central database, Support of different SQL databases (e. g. MySQL, PostgeSQL, ...)
131
- user authentication agains database or ldap directory
132
- easy to develope you own addon's (OTRS API)
133
- easy to write different frontends (e. g. X11, console, ...)
134
- own package manager (e. g. for application modules like webmail, calendar or
135
filemanager)
136
- a fast and useful application
137
138
139
%if 0%{?suse_version} < 900
140
SuSE series: ap
141
%endif
142
143
%prep
144
%setup
145
%patch0
146
147
%build
148
# copy config file
149
cp Kernel/Config.pm.dist Kernel/Config.pm
150
cd Kernel/Config/ && for foo in *.dist; do cp $foo `basename $foo .dist`; done && cd ../../
151
# copy all crontab dist files
152
for foo in var/cron/*.dist; do mv $foo var/cron/`basename $foo .dist`; done
153
# copy all .dist files
154
cp .procmailrc.dist .procmailrc
155
cp .fetchmailrc.dist .fetchmailrc
156
cp .mailfilter.dist .mailfilter
157
158
%install
159
# delete old RPM_BUILD_ROOT
160
rm -rf $RPM_BUILD_ROOT
161
# set DESTROOT
162
export DESTROOT="/opt/otrs/"
163
# create RPM_BUILD_ROOT DESTROOT
164
mkdir -p $RPM_BUILD_ROOT/$DESTROOT/
165
# copy files
166
cp -R . $RPM_BUILD_ROOT/$DESTROOT
167
# install init-Script and rc.config entry
168
%__install -d -m 755 $RPM_BUILD_ROOT%{_initdir}
169
%__install -d -m 755 $RPM_BUILD_ROOT%{_sbindir}
170
%__install -d -m 755 $RPM_BUILD_ROOT/etc/sysconfig
171
%if 0%{?suse_version}
172
%__install -d -m 744 $RPM_BUILD_ROOT/var/adm/fillup-templates
173
%endif
174
%__install -d -m 755 $RPM_BUILD_ROOT%{_apaconfdir}
175
176
%if 0%{?suse_version}
177
# replace apache with apache2
178
sed "s/rcapache/rcapache2/" scripts/suse-rcotrs-config > /tmp.otrs.$$ && mv /tmp.otrs.$$ scripts/suse-rcotrs-config
179
sed "s/apache/apache2/" scripts/suse-rcotrs > /tmp.otrs.$$ && mv /tmp.otrs.$$ scripts/suse-rcotrs
180
%__install -D -m 644 scripts/suse-rcotrs-config $RPM_BUILD_ROOT/var/adm/fillup-templates/sysconfig.otrs
181
%__install -m 755 scripts/suse-rcotrs $RPM_BUILD_ROOT%{_initdir}/otrs
182
rm -f $RPM_BUILD_ROOT/sbin/otrs
183
ln -s ../../etc/init.d/otrs $RPM_BUILD_ROOT%{_sbindir}/rcotrs
184
%else
185
%__install -m 755 scripts/redhat-rcotrs $RPM_BUILD_ROOT%{_initdir}/otrs
186
%__install -m 644 scripts/redhat-rcotrs-config $RPM_BUILD_ROOT/etc/sysconfig/otrs
187
%endif
188
%__install -m 644 scripts/apache2-httpd.include.conf $RPM_BUILD_ROOT%{_apaconfdir}/otrs.conf
189
%if 0%{?suse_version} > 1020
190
%fdupes $RPM_BUILD_ROOT/opt/otrs
191
%endif
192
193
# set permission
194
useradd %{_otrsusr} || :
195
#$RPM_BUILD_ROOT/opt/otrs/bin/otrs.SetPermissions.pl $RPM_BUILD_ROOT/opt/otrs %{_otrsusr} %{_apausr} %{_otrsgrp} %{_apagrp} || :
196
$RPM_BUILD_ROOT/opt/otrs/bin/otrs.SetPermissions.pl --otrs-user=%{_otrsusr} --web-user=%{_apausr} --otrs-group=%{_otrsgrp} --web-group=%{_apagrp} $RPM_BUILD_ROOT/opt/otrs || :
197
%pre
198
# remember about the installed version
199
if test -e /opt/otrs/RELEASE; then
200
cat /opt/otrs/RELEASE|grep VERSION|sed 's/VERSION = //'|sed 's/ /-/g' > /tmp/otrs-old.tmp
201
fi
202
# useradd
203
echo -n "Check OTRS user (/etc/passwd)... "
204
if cat /etc/passwd | grep %{_otrsusr} > /dev/null ; then
205
echo "%{_otrsusr} exists."
206
# update groups
207
usermod -g %{_otrsgrp} %{_otrsusr}
208
# update home dir
209
usermod -d /opt/otrs %{_otrsusr}
210
else
211
useradd %{_otrsusr} -d /opt/otrs/ -s /bin/false -g %{_otrsgrp} -c 'OTRS System User' && echo "%{_otrsusr} added."
212
fi
213
214
215
%post
216
%if 0%{?suse_version}
217
# sysconfig
218
%{fillup_and_insserv}
219
%endif
220
221
# if it's a major-update backup old version templates (maybe not compatible!)
222
if test -e /tmp/otrs-old.tmp; then
223
TOINSTALL=`echo %{version}| sed 's/..$//'`
224
OLDOTRS=`cat /tmp/otrs-old.tmp`
225
if echo $OLDOTRS | grep -v "$TOINSTALL" > /dev/null; then
226
echo "backup old (maybe not compatible) templates (of $OLDOTRS)"
227
for i in /opt/otrs/Kernel/Output/HTML/Standard/*.rpmnew;
228
do BF=`echo $i|sed 's/.rpmnew$//'`; mv -v $BF $BF.backup_maybe_not_compat_to.$OLDOTRS; mv $i $BF;
229
done
230
fi
231
rm -rf /tmp/otrs-old.tmp
232
fi
233
234
# OTRS 2.0 -> OTRS 2.1
235
# remove old ticket config file
236
if test -e /opt/otrs/Kernel/Config/Files/Ticket.pm; then
237
mv /opt/otrs/Kernel/Config/Files/Ticket.pm /opt/otrs/Kernel/Config/Files/Ticket.pm.not_longer_used
238
fi;
239
# remove old ticket postmaster config file
240
if test -e /opt/otrs/Kernel/Config/Files/TicketPostMaster.pm; then
241
mv /opt/otrs/Kernel/Config/Files/TicketPostMaster.pm /opt/otrs/Kernel/Config/Files/TicketPostMaster.pm.not_longer_used;
242
fi
243
# remove old faq config file
244
if test -e /opt/otrs/Kernel/Config/Files/FAQ.pm; then
245
mv /opt/otrs/Kernel/Config/Files/FAQ.pm /opt/otrs/Kernel/Config/Files/FAQ.pm.not_longer_used;
246
fi
247
248
#/opt/otrs/bin/otrs.SetPermissions.pl /opt/otrs %{_otrsusr} %{_apausr} %{_otrsgrp} %{_apagrp}
249
/opt/otrs/bin/otrs.SetPermissions.pl --otrs-user=%{_otrsusr} --web-user=%{_apausr} --otrs-group=%{_otrsgrp} --web-group=%{_apagrp} /opt/otrs
250
251
# note
252
HOST=`hostname -f`
253
echo ""
254
echo "Next steps: "
255
echo ""
256
%if 0%{?suse_version}
257
echo "[SuSEconfig]"
258
echo " Execute 'SuSEconfig' to configure the webserver."
259
%else
260
echo "[mysqld service]"
261
echo " Start mysqld 'service mysqld start'"
262
%endif
263
echo ""
264
echo "[start Apache and MySQL]"
265
echo " Execute 'rcapache2 restart' and 'rcmysql start' in case they don't run."
266
echo ""
267
echo "[install the OTRS database]"
268
echo " Use a webbrowser and open this link:"
269
echo " http://$HOST/otrs/installer.pl"
270
echo ""
271
echo "[OTRS services]"
272
%if 0%{?suse_version}
273
echo " Start OTRS 'rcotrs start-force' (rcotrs {start|stop|status|restart|start-force|stop-force})."
274
%else
275
echo " Start OTRS 'service otrs start' (service otrs {start|stop|status|restart)."
276
%endif
277
echo ""
278
echo "((enjoy))"
279
echo ""
280
echo " Your OTRS Team"
281
echo " http://otrs.org/"
282
echo ""
283
284
%clean
285
rm -rf $RPM_BUILD_ROOT
286
287
%files
288
%defattr(-,root,root)
289
%if 0%{?suse_version}
290
/var/adm/fillup-templates/sysconfig.otrs
291
%else
292
%config(noreplace) /etc/sysconfig/otrs
293
%endif
294
%config %{_apaconfdir}/otrs.conf
295
296
%{_initdir}/otrs
297
%if 0%{?suse_version}
298
%{_sbindir}/rcotrs
299
%endif
300
301
%config(noreplace) /opt/otrs/Kernel/Config.pm
302
%config(noreplace) /opt/otrs/Kernel/Config/GenericAgent.pm
303
##%config(noreplace) /opt/otrs/var/log/TicketCounter.log
304
%config(noreplace) /opt/otrs/.procmailrc
305
%config(noreplace) /opt/otrs/.fetchmailrc
306
%config(noreplace) /opt/otrs/.mailfilter
307
%config(noreplace) /opt/otrs/Kernel/Output/HTML/Standard/*.dtl
308
##%config(noreplace) /opt/otrs/Kernel/Output/HTML/Lite/*.dtl
309
%config(noreplace) /opt/otrs/Kernel/Language/*.pm
310
%config(noreplace) /opt/otrs/var/cron/*
311
%config(noreplace) /opt/otrs/var/logo-otrs.png
312
313
%dir /opt/otrs/
314
%dir /opt/otrs/Custom
315
/opt/otrs/Custom/README
316
/opt/otrs/RELEASE
317
/opt/otrs/ARCHIVE
318
/opt/otrs/.procmailrc.dist
319
/opt/otrs/.fetchmailrc.dist
320
/opt/otrs/.mailfilter.dist
321
%dir /opt/otrs/Kernel/
322
%dir /opt/otrs/Kernel/Config/
323
/opt/otrs/Kernel/Config.pm.dist
324
/opt/otrs/Kernel/Config/Files/
325
/opt/otrs/Kernel/Config/GenericAgent.pm.dist
326
/opt/otrs/Kernel/Config/GenericAgent.pm.examples
327
/opt/otrs/Kernel/Config/Defaults.pm
328
/opt/otrs/Kernel/Language.pm
329
%dir /opt/otrs/Kernel/Language/
330
/opt/otrs/Kernel/Modules*
331
%dir /opt/otrs/Kernel/Output/
332
%dir /opt/otrs/Kernel/Output/HTML/
333
%dir /opt/otrs/Kernel/Output/HTML/Standard/
334
##%dir /opt/otrs/Kernel/Output/HTML/Lite/
335
/opt/otrs/Kernel/Output/HTML/*.pm
336
/opt/otrs/Kernel/System*
337
/opt/otrs/bin*
338
/opt/otrs/scripts*
339
%dir /opt/otrs/var/
340
%dir /opt/otrs/var/article/
341
/opt/otrs/var/httpd/
342
%dir /opt/otrs/var/log/
343
%dir /opt/otrs/var/sessions/
344
%dir /opt/otrs/var/spool/
345
%dir /opt/otrs/var/cron/
346
%dir /opt/otrs/var/tmp/
347
##%dir /opt/otrs/var/pics
348
##%dir /opt/otrs/var/pics/stats/
349
%dir /opt/otrs/var/packages
350
/opt/otrs/var/packages/Support-*.opm
351
/opt/otrs/var/packages/iPhoneHandle-*.opm
352
/opt/otrs/Kernel/cpan-lib*
353
%dir /opt/otrs/var/stats
354
/opt/otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilEscalationDeadlineExpires.de.xml
355
/opt/otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilEscalationDeadlineExpires.en.xml
356
/opt/otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilResponseDeadlineExpires.de.xml
357
/opt/otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilResponseDeadlineExpires.en.xml
358
/opt/otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilSolutionDeadlineExpires.de.xml
359
/opt/otrs/var/stats/ListOfOpenTicketsSortedByTimeLeftUntilSolutionDeadlineExpires.en.xml
360
/opt/otrs/var/stats/ListOfTheMostTimeConsumingTickets.de.xml
361
/opt/otrs/var/stats/ListOfTheMostTimeConsumingTickets.en.xml
362
/opt/otrs/var/stats/ListOfTicketsClosedLastMonth.de.xml
363
/opt/otrs/var/stats/ListOfTicketsClosedLastMonth.en.xml
364
/opt/otrs/var/stats/ListOfTicketsClosedSortedByResponseTime.de.xml
365
/opt/otrs/var/stats/ListOfTicketsClosedSortedByResponseTime.en.xml
366
/opt/otrs/var/stats/ListOfTicketsClosedSortedBySolutionTime.de.xml
367
/opt/otrs/var/stats/ListOfTicketsClosedSortedBySolutionTime.en.xml
368
/opt/otrs/var/stats/ListOfTicketsCreatedLastMonth.de.xml
369
/opt/otrs/var/stats/ListOfTicketsCreatedLastMonth.en.xml
370
/opt/otrs/var/stats/Stats.NewTickets.de.xml
371
/opt/otrs/var/stats/Stats.NewTickets.en.xml
372
/opt/otrs/var/stats/Stats.StatusActionOverview.de.xml
373
/opt/otrs/var/stats/Stats.StatusActionOverview.en.xml
374
/opt/otrs/var/stats/Stats.TicketOverview.de.xml
375
/opt/otrs/var/stats/Stats.TicketOverview.en.xml
376
%dir /opt/otrs/var/fonts
377
/opt/otrs/var/fonts/DejaVuSans-Bold.ttf
378
/opt/otrs/var/fonts/DejaVuSans-BoldOblique.ttf
379
/opt/otrs/var/fonts/DejaVuSans-Oblique.ttf
380
/opt/otrs/var/fonts/DejaVuSans.ttf
381
/opt/otrs/var/fonts/DejaVuSansMono-Bold.ttf
382
/opt/otrs/var/fonts/DejaVuSansMono-BoldOblique.ttf
383
/opt/otrs/var/fonts/DejaVuSansMono-Oblique.ttf
384
/opt/otrs/var/fonts/DejaVuSansMono.ttf
385
%doc /opt/otrs/INSTAL*
386
%doc /opt/otrs/UPGRADING
387
%doc /opt/otrs/TODO
388
%doc /opt/otrs/COPYING
389
%doc /opt/otrs/CHANGES
390
%doc /opt/otrs/READM*
391
%doc /opt/otrs/doc*
392
%doc /opt/otrs/CREDITS
393
%doc /opt/otrs/COPYING-Third-Party
394
395
396
%changelog
397
* Thu Sep 29 2011 Carsten Schoene <cs@linux-administrator.com> - 3.0.10-1
398
- update to release 3.0.10
399
400
* Thu Apr 14 2011 Carsten Schoene <cs@linux-administrator.com> - 3.0.7-1
401
- update to release 3.0.7
402
403
* Tue Jan 18 2011 Carsten Schoene <cs@linux-administrator.com> - 3.0.5-1
404
- update to release 3.0.5
405
406
* Mon Nov 22 2010 Carsten Schoene <cs@linux-administrator.com> - 3.0.2-1
407
- update to release 3.0.2
408
409
* Wed Oct 27 2010 Carsten Schoene <cs@linux-administrator.com> - 2.4.9-1
410
- update to release 2.4.9
411
412
* Tue Apr 20 2010 Carsten Schoene <cs@linux-administrator.com> - 2.4.7-1
413
- update to release 2.4.7
414
415
* Sun Sep 13 2009 Carsten Schoene <cs@linux-administrator.com> - 2.4.4-1
416
- new release 2.4.4
417
418
* Fri Aug 14 2009 Carsten Schoene <cs@linux-administrator.com> - 2.4.3-1
419
- new release 2.4.3
420
421
* Thu Jul 30 2009 Carsten Schoene <cs@linux-administrator.com> - 2.4.2-1
422
- new release 2.4.2
423
424
* Fri Jan 01 2009 Carsten Schoene <cs@linux-administrator.com>
425
- new release 2.3.4
426
# Updated Chinese translation, thanks to Never Min!
427
# New Support Assessment module included - The integrated Support Assessment tool allows you to check relevant
428
Installation and configuration settings in order to optimize your OTRS. Therefor the integrated module checks
429
several system components e.g. database, operating system, webserver and OTRS itself.
430
# Bug #3459 - Tickets in the state "pending" were not escalated but were shown in the escalation overview
431
with a false timestamp calculation (34512 days).
432
# Bug #3367 - Escalation of a first response was not stopped by an external notification (which was working in OTRS 2.2.x).
433
# Bug #2730 - Sending mails to MS Exchange Server 2007 failed with Message: "Bad file descriptor!".
434
It was a network connection issues. Added a workaround to force the system trying to send it 3 times before giving up.
435
436
* Mon Nov 10 2008 Carsten Schoene <cs@linux-administrator.com>
437
- new release 2.3.3
438
# Bug #3314 - Escalation time was not updated correctly.
439
# Bug #3251 - Was not able to fetch emails via POP3s (Can't connect to) from gmail or MS Exchange mailboxes.
440
# Bug #3261 - Agent got escalation notifications in his web interface
441
for tickets with read-only permission.
442
(normally read/write permission is required to receive an escalation notification).
443
# Bug #3158 - Tickets in a pending state escalated although The escalation time should have been set out.
444
# Bug #3315 - GenericAgent was not working with pending time options.
445
An error log message got logged, the job was not executed.
446
447
* Tue Sep 30 2008 Carsten Schoene <cs@linux-administrator.com>
448
- new release 2.3.2
449
# Bug #3139 - Queue updates in the admin interface were not working with Oracle, Postgres and DB2 data bases.
450
# Bug #3076 - Ticket escalations based on update time were not working properly as the probably were ignored.
451
# Bug #3064 - Java Script Error appeared in phone and email ticket screen when "Internet Explorer 7" was used.
452
# Bug #3219 - It's not possible to use cache (TTL) feature for CustomerUser backends between 1-10.
453
# Bug #3216 - Customer Ticket search in customer panel returns links to internal articles. No permission screen appears.
454
# Bug #3198 - ACL is not working for services pull down in Customer Panel for creating new tickets.
455
- details of 2.3.1 release
456
* Data base- & code-improvements increase lead to a general performance gain of up to 20%.
457
* The support of an indexed full text search has been added.
458
The feature is disabled per default because additional disc space is needed.
459
The expected performance gain is 50%.
460
* Reduced reloads by using AJAX technology
461
* Instead of an ongoing recalculating of the escalation time during the run time,
462
it is only recalculated when it changes due to an event in OTRS.
463
It is then being stored in the ticket object which allows a direct access of
464
external reporting tools to the data base as well as a more efficient reporting
465
on escalations. This will also lead into a substantial performance improvement.
466
* Support of logical expressions: ticket-, customer- and FAQ- search supports logical expressions,
467
utilizing the AND, OR and ! operators as well as structuring expressions with parentheses.
468
* Search for ticket numbers by using the Browser OpenSearch feature (OpenSearch format).
469
* Search for ticket titles in the agent ticket search form and in the generic agent.
470
* Search for ticket close time in the agent ticket search form and in the generic agent.
471
* Expand/Collapse of articles: the article view can be expanded to display all articles at once.
472
The current article will remain in focus, and the preceding, or following articles will be displayed.
473
* Structured article tree - The article tree has been changed to a table.
474
* Printing of articles has been realized.
475
* The ticket title of linked tickets are displayed in case of a mouse over action.
476
* Merged tickets are displayed crossed out.
477
* Multiple files can be attached while moving a ticket using the ticket move mask.
478
* When splitting a ticket, all FreeText and Free Time data will be copied to the new ticket.
479
* Ticket Free Time fields can be declared as mandatory.
480
* A URL can be configured that takes the value of a FreeText Field and displays it as an URL link in the ticket.
481
* Added X-OTRS-TicketTime and X-OTRS-FollowUp-TicketTime.
482
* With OTRS 2.3 IMAP, IMAPS, and POP3S is supported to fetch mails from your MTA.
483
* In case of a lost password, OTRS is sending an e-mail to the user with a "password reset link".
484
After clicking this link the new password is sent to the user in a second e-mail.
485
* All agents that have a read permission on a certain queue can be selected for notification.
486
* An escalation view has been added that displays all tickets sorted by their remaining time to escalation.
487
- changes in 2.3.0 rc1
488
# Added Ingres 2006 R3 database experimental support.
489
# Updated norwegian translation, thanks to Fredrik Andersen!
490
# Updated finish translation, thanks to Mikko Hynninen!
491
# Updated catalonian translation, thanks to Antonio Linde!
492
# Updated french translation, thanks to Yann Richard!
493
# Updated persian translation, thanks to Amir Shams Parsa!
494
# Fixed Bug #2712 - Emails of a POP3 or IMAP box got deleted/lost independently of their actual processing status. A safety check has been implemented, that prevents e-Mails from getting lost.
495
# Fixed Bug #3098 - Ticket number search in the new link mask does'nt work correctly. '*' at the beginning and the end of a search string was added automatically.
496
# Fixed Bug #3012 - Statistic module was probably not accessible. It failed with a message "Got no UserLanguage".
497
# Fixed Bug #3066 - Login after initial setup sometimes failed. The new CPAN module XML::Parser::Lite crashed if XML::Parser was'nt installed, so the creation of config files (based on XML files) were denied.
498
- changes in 2.3.0 beta4
499
# Fixed bug #3053 - AJAX functionality within the ticket interface wasn't working properly when the cookies support was disabled in the browser.
500
# Fixed bug #3046 - Creating a new Phone- or Email-Ticket in the agent interface required to click twice on the "create" botton.
501
# Fixed bug #3047 - Once assigned it wasn't possible to reset services and slas to the option >none< in the AgentTicketNote screen.
502
# Fixed bug #2960 - OTRS update script "scripts/DBUpdate-to-2.3.pl" failed if there existed no config file (ZZZAuto.pm). The script now creates a new file if there is no existing config file (ZZZAuto.pm) found.
503
# Fixed bug #3029 - Search results in the agent interface of linkable objects were not sorted correctly.
504
# Fixed bug #3030 - If the same linked ticket was linked again the user didn't get the intended error message in the web interface.
505
# Fixed bug #3034 - The "Article sort order" in the Ticket Zoom screen wasn't working properly while using the new Expand/Collapse feature.
506
# Fixed bug #3059 - New ticket fulltext search feature wasn't working properly because of a missing "article_search" table in *.sql create scripts.
507
- changes in 2.3.0 beta3
508
# Fixed bug# 1565 - A responsible Agent wasn't updated when a new phone or e-mail ticket was created.
509
# Fixed bug# 2957 - Merged ticket wasn't shown as 'canceled' in the linked objects table.
510
# Fixed bug# 2969 - Users were unable to pass the login screen, error message: 'undefined value as a HASH reference at Kernel/System/Ticket/ IndexAccelerator/RuntimeDB.pm line 57'.
511
# Fixed bug# 2979 - Agents were unable to work on tickets, even with rw permissions error message: "no permission".
512
# Fixed bug# 2980 - Every time when IMAP or IMAPs was executed, Agents got a cron email (message: 'use of uninitialized value in numeric gt (>) at')
513
# Fixed bug# 3005 - AJAX functionality in the phone and email ticket mask wasn't working for Service and SLAs.
514
515
* Mon May 12 2008 Carsten Schoene <cs@linux-administrator.com>
516
- modified for cross-distribution build
517
518
* Thu Oct 18 2006 - martin+rpm@otrs.org
519
- added rename of old /opt/otrs/Kernel/Config/Files/(Ticket|TicketPostMaster|FAQ).pm files
520
* Sun Mar 25 2006 - martin+rpm@otrs.org
521
- added SUSE 10.0 support
522
523