File libmemcached.spec of Package libmemcached (Revision d41db42c97c2cdc3b917ae58bf999a31)
Currently displaying revision d41db42c97c2cdc3b917ae58bf999a31, show latest
1
Summary: memcached C library and command line tools
2
Name: libmemcached
3
Version: 0.10
4
Release: 1
5
License: BSD
6
Group: System Environment/Libraries
7
URL: http://tangent.org/552/libmemcached.html
8
9
Packager: Carsten Schoene <cs@linux-administrator.com>
10
11
Source: http://download.tangent.org/libmemcached-%{version}.tar.gz
12
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13
14
%description
15
libmemcached is a C client library to the memcached server
16
(http://danga.com/memcached). It has been designed to be light on memory
17
usage, and provide full access to server side methods.
18
19
It also implements several command line tools:
20
21
memcat - Copy the value of a key to standard output.
22
memflush - Flush the contents of your servers.
23
memrm - Remove a key(s) from the serrver.
24
memstat - Dump the stats of your servers to standard output.
25
memslap - Generate testing loads on a memcached cluster.
26
memcp - Copy files to memcached servers.
27
memerror - Creates human readable messages from libmemecached error codes.
28
29
%prep
30
%setup -q
31
32
%configure
33
34
%build
35
%{__make} %{_smp_mflags}
36
37
%install
38
%{__rm} -rf %{buildroot}
39
%{__make} install DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
40
41
%clean
42
%{__rm} -rf %{buildroot}
43
44
%files
45
%{_bindir}/memcat
46
%{_bindir}/memcp
47
%{_bindir}/memerror
48
%{_bindir}/memflush
49
%{_bindir}/memrm
50
%{_bindir}/memstat
51
%{_bindir}/memslap
52
%{_includedir}/libmemcached/memcached.h
53
%{_libdir}/libmemcached.a
54
%{_libdir}/libmemcached.la
55
%{_libdir}/libmemcached.so
56
%{_libdir}/libmemcached.so.1
57
%{_libdir}/libmemcached.so.1.0.1
58
%{_libdir}/pkgconfig/libmemcached.pc
59
%{_mandir}/man1/memcat.1.gz
60
%{_mandir}/man1/memcp.1.gz
61
%{_mandir}/man1/memerror.1.gz
62
%{_mandir}/man1/memflush.1.gz
63
%{_mandir}/man1/memrm.1.gz
64
%{_mandir}/man1/memslap.1.gz
65
%{_mandir}/man1/memstat.1.gz
66
%{_mandir}/man3/libmemcached.3.gz
67
%{_mandir}/man3/libmemcached_examples.3.gz
68
%{_mandir}/man3/memcached_add.3.gz
69
%{_mandir}/man3/memcached_append.3.gz
70
%{_mandir}/man3/memcached_behavior_get.3.gz
71
%{_mandir}/man3/memcached_behavior_set.3.gz
72
%{_mandir}/man3/memcached_cas.3.gz
73
%{_mandir}/man3/memcached_clone.3.gz
74
%{_mandir}/man3/memcached_create.3.gz
75
%{_mandir}/man3/memcached_decrement.3.gz
76
%{_mandir}/man3/memcached_delete.3.gz
77
%{_mandir}/man3/memcached_fetch.3.gz
78
%{_mandir}/man3/memcached_fetch_result.3.gz
79
%{_mandir}/man3/memcached_free.3.gz
80
%{_mandir}/man3/memcached_get.3.gz
81
%{_mandir}/man3/memcached_increment.3.gz
82
%{_mandir}/man3/memcached_mget.3.gz
83
%{_mandir}/man3/memcached_prepend.3.gz
84
%{_mandir}/man3/memcached_quit.3.gz
85
%{_mandir}/man3/memcached_replace.3.gz
86
%{_mandir}/man3/memcached_server_add.3.gz
87
%{_mandir}/man3/memcached_server_count.3.gz
88
%{_mandir}/man3/memcached_server_list.3.gz
89
%{_mandir}/man3/memcached_server_list_append.3.gz
90
%{_mandir}/man3/memcached_server_list_count.3.gz
91
%{_mandir}/man3/memcached_server_list_free.3.gz
92
%{_mandir}/man3/memcached_server_push.3.gz
93
%{_mandir}/man3/memcached_servers_parse.3.gz
94
%{_mandir}/man3/memcached_set.3.gz
95
%{_mandir}/man3/memcached_stat.3.gz
96
%{_mandir}/man3/memcached_stat_get_keys.3.gz
97
%{_mandir}/man3/memcached_stat_get_value.3.gz
98
%{_mandir}/man3/memcached_stat_servername.3.gz
99
%{_mandir}/man3/memcached_strerror.3.gz
100
%{_mandir}/man3/memcached_verbosity.3.gz
101
102
%changelog
103
* Sat Nov 24 2007 Carsten Schoene <cs@linux-administrator.com> - 0.10-1
104
- version bump to 0.10
105
- Added append binary test.
106
- Added MEMCACHED_BEHAVIOR_CACHE_LOOKUPS behavior so that you can save on
107
multiple DNS lookups.
108
- Added CAS support, though this is optional and must be enabled during
109
runtime.
110
- Added the utility memerror to create human readable error strings
111
from memcached errors (aka convert ints to strings)
112
- Fixed type in MEMCACHED_HOST_LOOKUP_FAILURE
113
- Fixed bug where hostname might not be null terminated
114
- Moved to using gethostbyname_r() on Linux to solve thread safety issue
115
- Added -rpath support for pkg-config
116
- Documentation fix for hash setting using
117
118
* Fri Nov 16 2007 Carsten Schoene <cs@linux-administrator.com> - 0.9-1
119
- version bump to 0.9
120
- fix for when no servers are definied.
121
- different buffers are now kept for different connections to
122
speed up async efforts
123
- Modified increment/decrement functions to return uint64_t values
124
- Fixed bug in cases where zero length keys were provided
125
- Thread cleanup issue in memslap
126
- No hostname lookup on reconnect
127
- Fix for flag settings (was doing hex by accident!)
128
- Support for 1.2.4 server additions "prepend" and "append" added.
129
- Added memcached_version()... not sure if I will make this public
130
or not.
131
132
* Mon Nov 5 2007 Brian Aker <brian@tangent.org> - 0.8-1
133
- Automated version number
134
135
* Wed Oct 3 2007 Brian Aker <brian@tangent.org> - 0.4-1
136
- See Changelog
137
138
* Mon Oct 1 2007 Brian Aker <brian@tangent.org> - 0.3-1
139
- Added memslap
140
141
* Fri Sep 28 2007 Jeff Fisher <guppy@techmonkeys.org> - 0.2-1
142
- Initial package
143