Search
j0ke.net Open Build Service
>
Projects
>
home:jg
:
http
>
nginx
> nginx.spec
Sign Up
|
Log In
Username
Password
Cancel
Overview
Repositories
Revisions
Requests
Users
Advanced
Attributes
Meta
File nginx.spec of Package nginx (Revision 4)
Currently displaying revision
4
,
show latest
%define nginx_user nginx %define nginx_group %{nginx_user} %define nginx_home %{_localstatedir}/lib/nginx %define nginx_home_tmp %{nginx_home}/tmp %define nginx_logdir %{_localstatedir}/log/nginx %define nginx_confdir %{_sysconfdir}/nginx %define nginx_datadir %{_datadir}/nginx %define nginx_webroot %{nginx_datadir}/html Name: nginx Version: 1.0.4 Release: 1 Summary: Robust, small and high performance http and reverse proxy server Group: System Environment/Daemons License: BSD URL: http://nginx.net/ BuildRoot: %{_tmppath}/%{name}-%{version}-root BuildRequires: pcre-devel,zlib-devel,openssl-devel,perl(ExtUtils::Embed) Requires: pcre,zlib,openssl Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) Requires(pre): shadow-utils Requires(post): chkconfig Requires(preun): chkconfig, initscripts Requires(postun): initscripts Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz Source1: %{name}.init Source2: %{name}.logrotate Source3: virtual.conf Source4: ssl.conf Source5: nginx-upstream-fair.tgz Source6: upstream-fair.conf Source7: %{name}.sysconfig Source8: ngx_slowfs_cache-1.5.tar.gz Source9: Nginx-limit-traffic-rate-module.tar.gz Source100: index.html Source101: poweredby.png Source102: nginx-logo.png Source103: 50x.html Source104: 404.html # removes -Werror in upstream build scripts. -Werror conflicts with # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors. Patch0: nginx-auto-cc-gcc.patch # configuration patch to match all the Fedora paths for logs, pid files # etc. Patch1: nginx-conf-0.7.x.patch # syslog patch, use syslog instead of nginx logfiles #Patch2: nginx-syslog.patch #Patch3: nginx-unix-sockets.diff %description Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3 proxy server written by Igor Sysoev. One third party module, nginx-upstream-fair, has been added. %prep %setup -q %patch0 -p0 %patch1 -p0 #%patch2 -p1 # %patch3 -p1 %{__tar} zxvf %{SOURCE5} %{__tar} zxvf %{SOURCE9} %build export DESTDIR=%{buildroot} ./configure \ --user=%{nginx_user} \ --group=%{nginx_group} \ --prefix=%{nginx_datadir} \ --sbin-path=%{_sbindir}/%{name} \ --conf-path=%{nginx_confdir}/%{name}.conf \ --error-log-path=%{nginx_logdir}/error.log \ --http-log-path=%{nginx_logdir}/access.log \ --http-client-body-temp-path=%{nginx_home_tmp}/client_body \ --http-proxy-temp-path=%{nginx_home_tmp}/proxy \ --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \ --pid-path=%{_localstatedir}/run/%{name}.pid \ --lock-path=%{_localstatedir}/lock/subsys/%{name} \ --with-http_ssl_module \ --with-http_realip_module \ --with-http_addition_module \ --with-http_sub_module \ --with-http_dav_module \ --with-http_flv_module \ --with-http_gzip_static_module \ --with-http_stub_status_module \ --with-mail \ --with-mail_ssl_module \ --with-debug \ --with-ipv6 \ --with-cc-opt="%{optflags} $(pcre-config --cflags)" \ --add-module=%{_builddir}/nginx-%{version}/nginx-upstream-fair \ --add-module=%{_builddir}/nginx-%{version}/Nginx-limit-traffic-rate-module %if 0%{?fedora_version} > 10 --with-file-aio %endif make %{?_smp_mflags} mv nginx-upstream-fair/README nginx-upstream-fair/README.nginx-upstream-fair %install rm -rf %{buildroot} make install DESTDIR=%{buildroot} INSTALLDIRS=vendor find %{buildroot} -type f -name .packlist -exec rm -f {} \; find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \; find %{buildroot} -type f -empty -exec rm -f {} \; find %{buildroot} -type f -exec chmod 0644 {} \; find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \; chmod 0755 %{buildroot}%{_sbindir}/nginx %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name} %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name} %{__install} -p -D -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/sysconfig/%{name} %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d %{__install} -p -m 0644 %{SOURCE3} %{SOURCE4} %{SOURCE6} %{buildroot}%{nginx_confdir}/conf.d %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp} %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir} %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot} %{__install} -p -m 0644 %{SOURCE100} %{SOURCE101} %{SOURCE102} %{SOURCE103} %{SOURCE104} %{buildroot}%{nginx_webroot} # convert to UTF-8 all files that give warnings. for textfile in CHANGES do mv $textfile $textfile.old iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old rm -f $textfile.old done %clean rm -rf %{buildroot} %pre %{_sbindir}/useradd -c "Nginx user" -s /bin/false -r -d %{nginx_home} %{nginx_user} 2>/dev/null || : %post /sbin/chkconfig --add %{name} %preun if [ $1 = 0 ]; then /sbin/service %{name} stop >/dev/null 2>&1 /sbin/chkconfig --del %{name} fi %postun if [ $1 -ge 1 ]; then /sbin/service %{name} condrestart > /dev/null 2>&1 || : fi %files %defattr(-,root,root,-) %doc LICENSE CHANGES README nginx-upstream-fair/README.nginx-upstream-fair %{nginx_datadir}/ %{_sbindir}/%{name} # %{_mandir}/man3/%{name}.3pm.gz %{_initrddir}/%{name} %dir %{nginx_confdir} %dir %{nginx_confdir}/conf.d %config(noreplace) %{nginx_confdir}/conf.d/*.conf %config(noreplace) %{nginx_confdir}/win-utf %config(noreplace) %{nginx_confdir}/%{name}.conf.default %config(noreplace) %{nginx_confdir}/mime.types.default %config(noreplace) %{nginx_confdir}/fastcgi_params %config(noreplace) %{nginx_confdir}/fastcgi_params.default %config(noreplace) %{nginx_confdir}/fastcgi.conf %config(noreplace) %{nginx_confdir}/fastcgi.conf.default %config(noreplace) %{nginx_confdir}/scgi_params %config(noreplace) %{nginx_confdir}/scgi_params.default %config(noreplace) %{nginx_confdir}/uwsgi_params %config(noreplace) %{nginx_confdir}/uwsgi_params.default %config(noreplace) %{nginx_confdir}/koi-win %config(noreplace) %{nginx_confdir}/koi-utf %config(noreplace) %{nginx_confdir}/%{name}.conf %config(noreplace) %{nginx_confdir}/mime.types %config(noreplace) %{_sysconfdir}/logrotate.d/%{name} %config(noreplace) %{_sysconfdir}/sysconfig/%{name} #%dir %{perl_vendorarch}/auto/%{name} #%{perl_vendorarch}/%{name}.pm #%{perl_vendorarch}/auto/%{name}/%{name}.so %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home} %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp} %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir} %changelog * Mon Oct 04 2010 Juergen Gotteswinter <jg at internetx.de> 0.8.52-1 - update to latest stable branch * Wed Nov 17 2009 Juergen Gotteswinter <jg at internetx.de> 0.7.64-1 - version bump to 0.7.64 * Wed Oct 28 2009 Juergen Gotteswinter <jg at internetx.de> 0.7.63-1 - version bump to 0.7.63 * Fri Oct 23 2009 Juergen Gotteswinter <jg at internetx.de> 0.7.62-3 - included nginx-socket-patch for unix socket support