Search
j0ke.net Open Build Service
>
Projects
>
ha
:
firewall
:
Snorby
>
rubygem-rack
> rubygem-rack.spec
Sign Up
|
Log In
Username
Password
Cancel
Overview
Repositories
Revisions
Requests
Users
Advanced
Attributes
Meta
File rubygem-rack.spec of Package rubygem-rack (Revision 5)
Currently displaying revision
5
,
show latest
# # spec file for package rubygem-rack # # Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # Name: rubygem-rack Version: 1.5.2 Release: 0 %define mod_name rack %define mod_full_name %{mod_name}-%{version} %define mod_branch -1_5 %define mod_weight 15 BuildRoot: %{_tmppath}/%{name}-%{version}-build BuildRequires: ruby-macros >= 1 Requires: ruby19 BuildRequires: ruby19-devel Requires(pre): update-alternatives Url: http://rack.github.com/ Source0: %{mod_full_name}.gem Source1: %{name}-rpmlintrc Summary: A modular Ruby webserver interface License: MIT Group: Development/Languages/Ruby %define rb_ver %{rb19_ver} %description Rack provides a minimal, modular and adaptable interface for developing web applications in Ruby. By wrapping HTTP requests and responses in the simplest way possible, it unifies and distills the API for web servers, web frameworks, and software in between (the so-called middleware) into a single method call. Also see http://rack.github.com/. %package doc Summary: RDoc documentation for %{mod_name} Group: Development/Languages/Ruby Requires: %{name} = %{version} %description doc Documentation generated at gem installation time. Usually in RDoc and RI formats. %package testsuite Summary: Test suite for %{mod_name} Group: Development/Languages/Ruby Requires: %{name} = %{version} %description testsuite Test::Unit or RSpec files, useful for developers. %prep #gem_unpack #if you need patches, apply them here and replace the # with a % sign in the surrounding lines #gem_build %build %install ## %gem19_install -f %gem19_install %{S:0} || : mv %{buildroot}%{_bindir}/rackup{,%{mod_branch}} ln -s rackup %{buildroot}%{_bindir}/rackup %post /usr/sbin/update-alternatives --install \ %{_bindir}/rackup rackup %{_bindir}/rackup%{mod_branch} %{mod_weight} %preun if [ "$1" = 0 ] ; then /usr/sbin/update-alternatives --remove rackup %{_bindir}/rackup%{mod_branch} fi %files %defattr(-,root,root,-) %ghost %config(noreplace) %{_bindir}/rackup %{_bindir}/rackup%{mod_branch} %{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_full_name}.gem %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/ %exclude %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test %{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_full_name}.gemspec %files doc %defattr(-,root,root,-) %doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_full_name}/ %files testsuite %defattr(-,root,root,-) %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test %changelog