Search
j0ke.net Open Build Service
>
Projects
>
devel
:
python
>
python-pthreading
> python-pthreading.spec
Sign Up
|
Log In
Username
Password
Cancel
Overview
Repositories
Revisions
Requests
Users
Advanced
Attributes
Meta
File python-pthreading.spec of Package python-pthreading
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")} Summary: Re-implement threading.Lock, RLock and Condition with libpthread Name: python-pthreading Version: 0.1.1 Release: 1%{?dist} License: GPLv2+ Group: System Environment/Libraries Source0: http://pypi.python.org/packages/source/p/pthreading/pthreading-%{version}.tar.gz Patch1: python-pthreading-01-COPYING-and-tests.patch URL: http://pypi.python.org/pypi/pthreading BuildRoot: %{_tmppath}/%{name}-%{version}-root %if 0%{!?suse_version} BuildArch: noarch %endif %if 0%{?suse_version} BuildRequires: python %else BuildRequires: python2 %endif %description The pthreading module provides Lock and Condition synchronization objects compatible with Python native threading module. The implementation, however, is based on POSIX thread library as delivered by the libpthread and has considerable performance benefits over Python 2.x's implementation. %prep %setup -q -n pthreading-%{version} %patch1 %build %install ##%{__python} setup.py install --root $RPM_BUILD_ROOT --install-lib %{python_sitelib} --prefix %{_prefix} %{__python} setup.py install -O1 --root %{buildroot} --prefix %{_prefix} %check %{__python} setup.py test %files %defattr(-,root,root) %doc COPYING %{python_sitelib}/pthread.py* %{python_sitelib}/pthreading.py* %{python_sitelib}/pthreading-%{version}-py*.egg-info %changelog * Mon Aug 27 2012 Dan Kenigsberg <danken@redhat.com> - 0.1.1-1 Initial take