Search
j0ke.net Open Build Service
>
Projects
>
GFS
:
experimental
>
openais
> openais.spec
Sign Up
|
Log In
Username
Password
Cancel
Overview
Repositories
Revisions
Requests
Users
Advanced
Attributes
Meta
File openais.spec of Package openais (Revision 9)
Currently displaying revision
9
,
show latest
#!BuildIgnore: post-build-checks # # spec file for package openais (Version 1.1.0) # # Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany. # # All modifications and additions to the file contributed by third parties # remain the property of their copyright owners, unless otherwise agreed # upon. The license for this file, and modifications and additions to the # file, is the same license as for the pristine package itself (unless the # license for the pristine package is not an Open Source License, in which # case the license is the MIT License). An "Open Source License" is a # license that conforms to the Open Source Definition (Version 1.9) # published by the Open Source Initiative. # Please submit bugfixes or comments via http://bugs.opensuse.org/ # # norootforbuild %if 0%{?suse_version} ##%define _libexecdir %{_libdir} %define _libexecdir %{_prefix}/libexec %endif %define ais_uid 39 %define ais_user ais %if 0%{?fedora_version} %define pkg_group System Environment/Base %else %define pkg_group Productivity/Clustering/HA %endif Name: openais Summary: The OpenAIS Standards-Based Cluster Framework executive and APIs Version: 1.1.0 Release: 13 License: BSD 3-Clause Group: %{pkg_group} Url: http://www.openais.org/ Source0: %{name}-%{version}.tar.gz Source1: openais.init Patch0: openais-%{version}-defaultconfig.patch BuildRequires: corosynclib-devel BuildRoot: %{_tmppath}/%{name}-%{version}-build Requires(pre): /usr/sbin/useradd Requires(post): /sbin/chkconfig Requires(preun): /sbin/chkconfig %description This package contains the openais executive, openais service handlers, default configuration files and init script. Authors: -------- Steven Dake Mark Haverkamp Muni Bajpai Daniel McNiel Miyotaka Sakai Daniel Stodden Kristen Smith Patrick Caulfield Fabien Thomas Hans Feldt Lars Holm Anders Eriksson Renaud Metrich Frederic Hermann Alejandro Lopez David Teigland Robert Peterson Abhijith Das %package -n libopenais3 License: BSD 3-Clause Summary: The OpenAIS Standards-Based Cluster Framework executive and APIs Group: %{pkg_group} %description -n libopenais3 This package contains the openais executive, openais service handlers, default configuration files and init script. Authors: -------- Steven Dake Mark Haverkamp Muni Bajpai Daniel McNiel Miyotaka Sakai Daniel Stodden Kristen Smith Patrick Caulfield Fabien Thomas Hans Feldt Lars Holm Anders Eriksson Renaud Metrich Frederic Hermann Alejandro Lopez David Teigland Robert Peterson Abhijith Das %package -n libopenais-devel License: BSD 3-Clause Summary: The openais Standards-Based Cluster Framework libraries Group: Development/Libraries/C and C++ Requires: %{name} = %{version}-%{release} Requires: libopenais3 = %{version}-%{release} %description -n libopenais-devel This package contains the libraries and include files used to develop using openais APIs. Authors: -------- Steven Dake Mark Haverkamp Muni Bajpai Daniel McNiel Miyotaka Sakai Daniel Stodden Kristen Smith Patrick Caulfield Fabien Thomas Hans Feldt Lars Holm Anders Eriksson Renaud Metrich Frederic Hermann Alejandro Lopez David Teigland Robert Peterson Abhijith Das %prep %setup %patch0 %build # -O3 required for performance reasons # So we get proper debug output, for now we don't compile with O3 #CFLAGS="$(echo '%{optflags}' | sed -e 's/-O[0-9]*//') -O3" #CFLAGS="$(echo '%{optflags}')" ##make CFLAGS="$RPM_OPT_FLAGS" LIBDIR=%{_libdir}/openais LCRSODIR=%{_libexecdir}/lcrso PREFIX=%{_prefix} OPENAIS_BUILD=DEBUG %configure --with-lcrso-dir=%{_libdir}/lcrso make CFLAGS="$CFLAGS" %install rm -rf $RPM_BUILD_ROOT ##make LIBDIR=%{_libdir}/openais DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix} LCRSODIR=%{_libexecdir}/lcrso STATICLIBS=NO OPENAIS_BUILD=DEBUG install make install DESTDIR=$RPM_BUILD_ROOT STATICLIBS=NO mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} mkdir -p $RPM_BUILD_ROOT%{_initrddir} install -m 644 CHANGELOG LICENSE README.amf \ $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/ install -m 755 %{S:1} $RPM_BUILD_ROOT%{_initrddir}/openais find $RPM_BUILD_ROOT -name '*.a' -type f -print0 | xargs -0 rm -f find $RPM_BUILD_ROOT -name '*.la' -type f -print0 | xargs -0 rm -f %if 0%{?suse_version} ln -sf ../../etc/init.d/openais $RPM_BUILD_ROOT/%{_sbindir}/rcopenais %endif %clean rm -rf $RPM_BUILD_ROOT %pre %if 0%{?fedora_version} /usr/sbin/fedora-useradd %{ais_uid} -r -s /sbin/nologin -d '/' -M \ -c 'openais Standards Based Cluster Framework' %{ais_user} &>/dev/null || : %else if getent passwd %{ais_user} >/dev/null then : OK hacluster user already present else /usr/sbin/useradd -c "openais Standards Based Cluster Framework" \ -r -d '/' -u %{ais_uid} %{ais_user} 2>/dev/null || : fi %endif %post %if 0%{?suse_version} %{fillup_and_insserv -n heartbeat} %else /sbin/chkconfig --add openais || : %endif /sbin/ldconfig %preun %if 0%{?suse_version} %stop_on_removal openais %else if [ $1 -eq 0 ]; then %{_initrddir}/openais stop &>/dev/null || : fi %endif /sbin/chkconfig --del openais || : %postun %if 0%{?suse_version} %restart_on_update openais %{insserv_cleanup} %else [ "$1" -ge "1" ] && %{_initrddir}/openais condrestart &>/dev/null || : %endif /sbin/ldconfig %post -n libopenais3 -p /sbin/ldconfig %postun -n libopenais3 -p /sbin/ldconfig %files %defattr(-,root,root,-) %dir %{_docdir}/%{name}-%{version} %dir %{_docdir}/%{name}-%{version}/html %doc %{_docdir}/%{name}-%{version}/LICENSE %doc %{_docdir}/%{name}-%{version}/README.amf %doc %{_docdir}/%{name}-%{version}/html/*.html %{_sysconfdir}/corosync/amf.conf.example %{_sbindir}/aisexec %{_sbindir}/openais-instantiate %{_initrddir}/openais %if 0%{?suse_version} %{_sbindir}/rcopenais %endif %dir %{_libdir}/lcrso %{_libdir}/lcrso/*.lcrso %{_mandir}/man8/*.8* %{_mandir}/man5/openais.conf.5* %{_mandir}/man5/amf.conf.5* %files -n libopenais3 %defattr(-,root,root,-) %dir %{_libdir}/openais %{_libdir}/libSa*.so.3.0.0 %files -n libopenais-devel %defattr(-,root,root,-) %dir %{_docdir}/%{name}-%{version} %doc %{_docdir}/%{name}-%{version}/CHANGELOG %dir %{_includedir}/openais/ %{_libdir}/libSa*.so %{_libdir}/libSa*.so,3 %{_includedir}/openais/*.h %{_mandir}/man3/cpg_*.3* %{_mandir}/man3/evs_*.3* %{_libdir}/pkgocnfig}/libSa*.pc %changelog